Bug 911385 - Quartz errors in server log
Quartz errors in server log
Status: CLOSED DUPLICATE of bug 906500
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.2
Unspecified Unspecified
high Severity high
: ---
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-14 16:30 EST by Mike Foley
Modified: 2013-03-11 14:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 14:45:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server log (876.46 KB, application/octet-stream)
2013-02-14 16:30 EST, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2013-02-14 16:30:17 EST
Created attachment 697414 [details]
server log

Description of problem:  Quartz errors in server log


Version-Release number of selected component (if applicable):  JON 3.2


How reproducible:
100%

Steps to Reproduce:
1.  examination of server.log 
2.
3.
  
Actual results:  see attached


Expected results:  no quartz errors 


Additional info:

8:01:58,226 ERROR [org.jboss.as.ejb3.invocation] (EJB default - 1) JBAS014134: EJB Invocation failed on component SchedulerBean for method public abstract void org.rhq.enterprise.server.scheduler.EnhancedScheduler.scheduleSimpleRepeatingJob(java.lang.Class,boolean,boolean,long,long) throws org.quartz.SchedulerException: javax.ejb.EJBException: Unexpected Error
	at org.jboss.as.ejb3.tx.CMTTxInterceptor.handleExceptionInOurTx(CMTTxInterceptor.java:162) [jboss-as-ejb3.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.ejb3.tx.CMTTxInterceptor.invokeInOurTx(CMTTxInterceptor.java:229) [jboss-as-ejb3.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.ejb3.tx.CMTTxInterceptor.required(CMTTxInterceptor.java:303) [jboss-as-ejb3.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.ejb3.tx.CMTTxInterceptor.processInvocation(CMTTxInterceptor.java:189) [jboss-as-ejb3.jar:7.1.2.Final-redhat-1]
	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.jboss.as.ejb3.component.interceptors.CurrentInvocationContextInterceptor.processInvocation(CurrentInvocationContextInterceptor.java:41) [jboss-as-ejb3.jar:7.1.2.Final-redhat-1]
	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.jboss.as.ejb3.component.interceptors.ShutDownInterceptorFactory$1.processInvocation(ShutDownInterceptorFactory.java:42) [jboss-as-ejb3.jar:7.1.2.Final-redhat-1]
	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.jboss.as.ejb3.component.interceptors.LoggingInterceptor.processInvocation(LoggingInterceptor.java:59) [jboss-as-ejb3.jar:7.1.2.Final-redhat-1]
	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.jboss.as.ee.component.NamespaceContextInterceptor.processInvocation(NamespaceContextInterceptor.java:50) [jboss-as-ee.jar:7.1.2.Final-redhat-1]
	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.jboss.as.ejb3.component.interceptors.AdditionalSetupInterceptor.processInvocation(AdditionalSetupInterceptor.java:32) [jboss-as-ejb3.jar:7.1.2.Final-redhat-1]
	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.jboss.as.ee.component.TCCLInterceptor.processInvocation(TCCLInterceptor.java:45) [jboss-as-ee.jar:7.1.2.Final-redhat-1]
	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.jboss.invocation.ChainedInterceptor.processInvocation(ChainedInterceptor.java:61) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.jboss.as.ee.component.ViewService$View.invoke(ViewService.java:165) [jboss-as-ee.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.ee.component.ViewDescription$1.processInvocation(ViewDescription.java:176) [jboss-as-ee.jar:7.1.2.Final-redhat-1]
	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.jboss.invocation.ChainedInterceptor.processInvocation(ChainedInterceptor.java:61) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.jboss.as.ee.component.ProxyInvocationHandler.invoke(ProxyInvocationHandler.java:72) [jboss-as-ee.jar:7.1.2.Final-redhat-1]
	at org.rhq.enterprise.server.scheduler.SchedulerLocal$$$view10.scheduleSimpleRepeatingJob(Unknown Source) [rhq-enterprise-server-ejb3.jar:4.6.0.JON]
	at org.rhq.enterprise.server.core.StartupBean.scheduleJobs(StartupBean.java:509) [rhq-enterprise-server-ejb3.jar:4.6.0.JON]
	at org.rhq.enterprise.server.core.StartupBean.init(StartupBean.java:198) [rhq-enterprise-server-ejb3.jar:4.6.0.JON]
Comment 1 Charles Crouch 2013-02-25 15:42:01 EST
From mfoley: just install, start it up and bang
Comment 2 John Mazzitelli 2013-03-11 14:45:36 EDT
the 20th line in the server log:

17:46:50,885 ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 58) JBAS014612: Operation ("add") failed - address: ([("subsystem" => "webservices")]): java.lang.RuntimeException: java.net.UnknownHostException: foleymonsterbox1.foleyhomenetwork: foleymonsterbox1.foleyhomenetwork

whose cause is:

Caused by: java.net.UnknownHostException: foleymonsterbox1.foleyhomenetwork: foleymonsterbox1.foleyhomenetwork
	at java.net.InetAddress.getLocalHost(InetAddress.java:1426) [rt.jar:1.6.0_20]
	at org.jboss.ws.common.management.AbstractServerConfig.setWebServiceHost(AbstractServerConfig.java:106)

The hostname of this machine is foobar'ed - all bets are off when JBossAS can't even get the machine's local host address.

That said, regarding Quartz, the full stack has this as its cause:

Caused by: java.lang.NoClassDefFoundError: oracle/sql/BLOB

This was already fixed. See bug #906500

*** This bug has been marked as a duplicate of bug 906500 ***

Note You need to log in before you can comment on or make changes to this bug.