Bug 911437 - [abrt] 4ti2-1.5-6.fc18: gcd_column: Process /usr/lib64/4ti2/bin/zsolve was killed by signal 11 (SIGSEGV)
Summary: [abrt] 4ti2-1.5-6.fc18: gcd_column: Process /usr/lib64/4ti2/bin/zsolve was ki...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: latte-integrale
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c28ad8254669be8574f5916f4f6...
Depends On:
Blocks: 911439
TreeView+ depends on / blocked
 
Reported: 2013-02-15 01:46 UTC by Rex Dieter
Modified: 2013-05-24 20:34 UTC (History)
1 user (show)

Fixed In Version: Macaulay2-1.5-0.6.20130214.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-24 20:34:50 UTC


Attachments (Terms of Use)
File: backtrace (23.82 KB, text/plain)
2013-02-15 01:46 UTC, Rex Dieter
no flags Details
File: cgroup (132 bytes, text/plain)
2013-02-15 01:46 UTC, Rex Dieter
no flags Details
File: core_backtrace (433 bytes, text/plain)
2013-02-15 01:46 UTC, Rex Dieter
no flags Details
File: dso_list (745 bytes, text/plain)
2013-02-15 01:46 UTC, Rex Dieter
no flags Details
File: environ (4.09 KB, text/plain)
2013-02-15 01:46 UTC, Rex Dieter
no flags Details
File: limits (1.29 KB, text/plain)
2013-02-15 01:46 UTC, Rex Dieter
no flags Details
File: maps (3.92 KB, text/plain)
2013-02-15 01:46 UTC, Rex Dieter
no flags Details
File: open_fds (390 bytes, text/plain)
2013-02-15 01:46 UTC, Rex Dieter
no flags Details
File: proc_pid_status (928 bytes, text/plain)
2013-02-15 01:46 UTC, Rex Dieter
no flags Details
File: smolt_data (2.63 KB, text/plain)
2013-02-15 01:46 UTC, Rex Dieter
no flags Details
File: var_log_messages (977 bytes, text/plain)
2013-02-15 01:46 UTC, Rex Dieter
no flags Details
Macaulay2 build log (1.06 MB, text/plain)
2013-03-20 23:15 UTC, Jerry James
no flags Details

Description Rex Dieter 2013-02-15 01:46:24 UTC
Description of problem:
Trying to build Macaulay2

Version-Release number of selected component:
4ti2-1.5-6.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/lib64/4ti2/bin/zsolve -H -q /tmp/M2-26658-0/1
crash_function: gcd_column
executable:     /usr/lib64/4ti2/bin/zsolve
kernel:         3.7.5-201.fc18.x86_64
uid:            1000

Truncated backtrace:
Thread no. 1 (3 frames)
 #0 gcd_column at ../../src/zsolve/VectorArray.hpp:197
 #1 _4ti2_zsolve_::Lattice<int>::reduce_gaussian at ../../src/zsolve/Lattice.hpp:102
 #2 _4ti2_zsolve_::ZSolveAPI<int>::compute at ../../src/zsolve/ZSolveAPI.hpp:381

Comment 1 Rex Dieter 2013-02-15 01:46:26 UTC
Created attachment 697487 [details]
File: backtrace

Comment 2 Rex Dieter 2013-02-15 01:46:28 UTC
Created attachment 697488 [details]
File: cgroup

Comment 3 Rex Dieter 2013-02-15 01:46:29 UTC
Created attachment 697489 [details]
File: core_backtrace

Comment 4 Rex Dieter 2013-02-15 01:46:31 UTC
Created attachment 697490 [details]
File: dso_list

Comment 5 Rex Dieter 2013-02-15 01:46:32 UTC
Created attachment 697491 [details]
File: environ

Comment 6 Rex Dieter 2013-02-15 01:46:34 UTC
Created attachment 697492 [details]
File: limits

Comment 7 Rex Dieter 2013-02-15 01:46:35 UTC
Created attachment 697493 [details]
File: maps

Comment 8 Rex Dieter 2013-02-15 01:46:36 UTC
Created attachment 697494 [details]
File: open_fds

Comment 9 Rex Dieter 2013-02-15 01:46:38 UTC
Created attachment 697495 [details]
File: proc_pid_status

Comment 10 Rex Dieter 2013-02-15 01:46:39 UTC
Created attachment 697496 [details]
File: smolt_data

Comment 11 Rex Dieter 2013-02-15 01:46:41 UTC
Created attachment 697497 [details]
File: var_log_messages

Comment 12 Jerry James 2013-03-20 23:15:27 UTC
Created attachment 713517 [details]
Macaulay2 build log

Sorry to be so slow on this.  I'm tracking down multiple LattE bugs.

I attempted to build Macaulay2 for Rawhide today, and it didn't make it to the point where zsolve crashed.  I'll attach the mock build log.  At least, I did not get an abrt message about a crash.  Can you tell what's happening from the build log?

Comment 13 Jerry James 2013-03-21 14:39:32 UTC
Rex, do you still have a build log from your attempt?  I need to find some input that causes this crash, so I can reproduce.  The crash indicates that the damage had already been done at some earlier point.  I've been hunting through the Macaulay2 sources trying to figure out what input caused this, but I'm having a hard time figuring it out.  Any help is much appreciated.

Comment 14 Rex Dieter 2013-03-21 16:18:15 UTC
I can try again today, no problem.

Easy to reproduce even on f18, try rebuilding there.

Comment 15 Jerry James 2013-03-21 16:31:47 UTC
I finally read enough Macaulay2 code to find the input.  Put this into a file named test.lat:

3 4
1 0 1 0
0 1 0 1
0 0 1 1

Then run "hilbert test".  Boom!  Okay, now that I can reproduce, I'll dig into it and see what's going wrong.

Comment 16 Jerry James 2013-03-21 19:06:09 UTC
This appears to be a bug in the reduce_gaussian function.  I notified upstream, and they say they will look at the problem soon.  I tried to figure it out myself, but since I don't really understand the algorithm, I'm afraid that anything I try to do to fix this problem will sacrifice correctness.

Comment 17 Fedora Update System 2013-05-12 04:27:47 UTC
sagemath-5.9-3.fc19,Macaulay2-1.5-0.6.20130214.fc19,linbox-1.3.2-10.fc19,Singular-3.1.5-5.fc19,polybori-0.8.3-4.fc19,latte-integrale-1.5.3-8.fc19,eclib-20120830-3.fc19,flint-1.6-7.fc19,m4rie-20130416-2.fc19,ntl-6.0.0-1.fc19,m4ri-20130416-1.fc19,libfplll-4.0.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sagemath-5.9-3.fc19,Macaulay2-1.5-0.6.20130214.fc19,linbox-1.3.2-10.fc19,Singular-3.1.5-5.fc19,polybori-0.8.3-4.fc19,latte-integrale-1.5.3-8.fc19,eclib-20120830-3.fc19,flint-1.6-7.fc19,m4rie-20130416-2.fc19,ntl-6.0.0-1.fc19,m4ri-20130416-1.fc19,libfplll-4.0.3-1.fc19

Comment 18 Fedora Update System 2013-05-12 17:51:07 UTC
Package sagemath-5.9-3.fc19, Macaulay2-1.5-0.6.20130214.fc19, linbox-1.3.2-10.fc19, Singular-3.1.5-5.fc19, polybori-0.8.3-4.fc19, latte-integrale-1.5.3-8.fc19, eclib-20120830-3.fc19, flint-1.6-7.fc19, m4rie-20130416-2.fc19, ntl-6.0.0-1.fc19, m4ri-20130416-1.fc19, libfplll-4.0.3-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sagemath-5.9-3.fc19 Macaulay2-1.5-0.6.20130214.fc19 linbox-1.3.2-10.fc19 Singular-3.1.5-5.fc19 polybori-0.8.3-4.fc19 latte-integrale-1.5.3-8.fc19 eclib-20120830-3.fc19 flint-1.6-7.fc19 m4rie-20130416-2.fc19 ntl-6.0.0-1.fc19 m4ri-20130416-1.fc19 libfplll-4.0.3-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7968/sagemath-5.9-3.fc19,Macaulay2-1.5-0.6.20130214.fc19,linbox-1.3.2-10.fc19,Singular-3.1.5-5.fc19,polybori-0.8.3-4.fc19,latte-integrale-1.5.3-8.fc19,eclib-20120830-3.fc19,flint-1.6-7.fc19,m4rie-20130416-2.fc19,ntl-6.0.0-1.fc19,m4ri-20130416-1.fc19,libfplll-4.0.3-1.fc19
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2013-05-14 03:44:52 UTC
Package Macaulay2-1.5-0.6.20130214.fc19, linbox-1.3.2-10.fc19, Singular-3.1.5-5.fc19, polybori-0.8.3-4.fc19, latte-integrale-1.5.3-8.fc19, eclib-20120830-3.fc19, flint-1.6-7.fc19, m4rie-20130416-2.fc19, ntl-6.0.0-1.fc19, m4ri-20130416-1.fc19, libfplll-4.0.3-1.fc19, sagemath-5.9-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Macaulay2-1.5-0.6.20130214.fc19 linbox-1.3.2-10.fc19 Singular-3.1.5-5.fc19 polybori-0.8.3-4.fc19 latte-integrale-1.5.3-8.fc19 eclib-20120830-3.fc19 flint-1.6-7.fc19 m4rie-20130416-2.fc19 ntl-6.0.0-1.fc19 m4ri-20130416-1.fc19 libfplll-4.0.3-1.fc19 sagemath-5.9-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7968/sagemath-5.9-5.fc19,Macaulay2-1.5-0.6.20130214.fc19,linbox-1.3.2-10.fc19,Singular-3.1.5-5.fc19,polybori-0.8.3-4.fc19,latte-integrale-1.5.3-8.fc19,eclib-20120830-3.fc19,flint-1.6-7.fc19,m4rie-20130416-2.fc19,ntl-6.0.0-1.fc19,m4ri-20130416-1.fc19,libfplll-4.0.3-1.fc19
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2013-05-24 20:34:50 UTC
Macaulay2-1.5-0.6.20130214.fc19, linbox-1.3.2-10.fc19, Singular-3.1.5-5.fc19, polybori-0.8.3-4.fc19, latte-integrale-1.5.3-8.fc19, eclib-20120830-3.fc19, flint-1.6-7.fc19, m4rie-20130416-2.fc19, ntl-6.0.0-1.fc19, m4ri-20130416-1.fc19, libfplll-4.0.3-1.fc19, sagemath-5.9-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.