Bug 911496 - Change in module structure prevents JBDS to create an EAP 6.1 server
Summary: Change in module structure prevents JBDS to create an EAP 6.1 server
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Server
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Jason Greene
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-15 07:57 UTC by Radim Hatlapatka
Modified: 2014-05-27 01:29 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Jason Greene can you please provide some doc text for documentarist regarding information regarding versions of JBDS (JBDS 6.1 and higher) which support EAP 6.1 and the reasoning behind it. Cause: Consequence: Fix: Result:
Clone Of:
Environment:
Last Closed: 2013-07-21 17:04:46 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Issue Tracker JBIDE-13537 Blocker Closed Unable to create EAP6.1 server [4.0.1 maintenance] 2015-07-30 05:48:57 UTC

Description Radim Hatlapatka 2013-02-15 07:57:31 UTC
JBDS 5 and JBDS 6 is not able to create (work with) EAP 6.1 server because of change in module structure (https://issues.jboss.org/browse/MODULES-154):

https://issues.jboss.org/browse/JBIDE-13537


There exists a workaround, to make symlink from old location to location in the new structure, see https://community.jboss.org/message/796711?_sscc=t

Comment 1 Rostislav Svoboda 2013-02-15 08:16:34 UTC
We need to sync new JBDS 5/6 release with EAP 610 to provide appropriate support for developers for new EAP version. Adding qa_ack.

Comment 2 JBoss JIRA Server 2013-02-28 15:43:28 UTC
Rob Stryker <rob.stryker@jboss.com> made a comment on jira JBIDE-13537

Mock test and real test added. pushed to maintenance.

Comment 3 JBoss JIRA Server 2013-03-05 09:24:39 UTC
Rastislav Wagner <rawagner@redhat.com> updated the status of jira JBIDE-13537 to Closed

Comment 4 JBoss JIRA Server 2013-03-05 09:24:39 UTC
Rastislav Wagner <rawagner@redhat.com> made a comment on jira JBIDE-13537

verified in JBDS 6.0.1 v20130304-0526-B338

Comment 5 JBoss JIRA Server 2013-03-08 11:03:26 UTC
Rob Stryker <rob.stryker@jboss.com> updated the status of jira JBIDE-13537 to Reopened

Comment 6 JBoss JIRA Server 2013-03-08 11:05:08 UTC
Rob Stryker <rob.stryker@jboss.com> updated the status of jira JBIDE-13537 to Resolved

Comment 7 JBoss JIRA Server 2013-03-11 10:28:43 UTC
Martin Malina <mmalina@redhat.com> updated the status of jira JBIDE-13537 to Closed

Comment 8 JBoss JIRA Server 2013-03-11 10:28:43 UTC
Martin Malina <mmalina@redhat.com> made a comment on jira JBIDE-13537

Closing again.

Comment 9 JBoss JIRA Server 2013-03-13 03:28:36 UTC
Michelle Murray <mmurray@redhat.com> updated the status of jira JBIDE-13537 to Reopened

Comment 10 JBoss JIRA Server 2013-03-13 03:28:36 UTC
Michelle Murray <mmurray@redhat.com> made a comment on jira JBIDE-13537

Reopening to edit release notes text

Comment 11 JBoss JIRA Server 2013-03-13 03:29:26 UTC
Michelle Murray <mmurray@redhat.com> updated the status of jira JBIDE-13537 to Resolved

Comment 12 JBoss JIRA Server 2013-03-13 03:29:26 UTC
Michelle Murray <mmurray@redhat.com> made a comment on jira JBIDE-13537

Resetting resolution after reopening to edit release notes text

Comment 13 JBoss JIRA Server 2013-03-19 13:08:03 UTC
Rastislav Wagner <rawagner@redhat.com> updated the status of jira JBIDE-13537 to Closed

Comment 14 JBoss JIRA Server 2013-03-19 13:08:03 UTC
Rastislav Wagner <rawagner@redhat.com> made a comment on jira JBIDE-13537

closing.

Comment 15 Anne-Louise Tangring 2013-04-10 19:25:22 UTC
Adding back the acks that were removed when I set component.

Comment 18 Radim Hatlapatka 2013-05-17 14:06:54 UTC
EAP 6.1 is compatible with JBDS 6.0.1 which is currently the latest released version

Comment 20 John Doyle 2013-07-02 18:25:44 UTC
Think this should be closed.

Comment 21 Radim Hatlapatka 2013-07-03 08:11:34 UTC
It depends if we want to track that EAP 6.1 is no longer supported by older versions of JBDS than 6.0.1 (that means mainly by JBDS 5)


Note You need to log in before you can comment on or make changes to this bug.