Bug 91152 - URL for live content is wrong.
Summary: URL for live content is wrong.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Justin Ross
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 88926
TreeView+ depends on / blocked
 
Reported: 2003-05-19 14:30 UTC by Jon Orris
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 23:04:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon Orris 2003-05-19 14:30:26 UTC
Description of problem:
@31265

The URL for live content is wrong. If you go to the public site, the url link
for a published item will be something like:
http://localhost:8080/ccm/articles/index/testarticle?g11n.enc=ISO-8859-1

This is incorrect. However, clicking on the .. link will take you to a page
where the item exists, and has the correct url:
http://localhost:8080/ccm/articles/testarticle/?g11n.enc=ISO-8859-1

There is a secondary problem with noone but SWA being able to access this, but
that's a separate ticket.

Comment 1 Justin Ross 2003-06-03 18:22:50 UTC
This is fixed in perforce 31962.

Comment 2 Scott Seago 2003-06-04 14:51:30 UTC
I think this is just a problem with relative links -- since URLs no longer end
in .jsp for the most part, they're redirected to "foo/" so relative links are
effectively  "foo/bar" rather than "bar"

Comment 3 Jon Orris 2003-06-04 16:02:05 UTC
This is still an issue @31994. The .. link is missing, though.


Comment 4 Justin Ross 2003-06-05 16:36:40 UTC
I believe I fixed this in perforce 32056, at least wrt the URLs in the index
page.  Is there another case where URLs are generated without extensions?

Comment 5 Jon Orris 2003-06-05 21:17:40 UTC
Still appears in the index page @32060
http://localhost:8080/ccm/articles/index/foobar.jsp?g11n.enc=UTF-8 is the URL in
the index page

http://localhost:8080/ccm/articles/foobar.jsp?g11n.enc=UTF-8 is the correct URL.


Comment 6 Justin Ross 2003-06-05 21:41:16 UTC
Once I watched Jon reproduce his way, I saw what the problem was.  Fixed in
perforce 32073.

Comment 7 Jon Orris 2003-06-06 23:04:03 UTC
Fixed


Note You need to log in before you can comment on or make changes to this bug.