Bug 911573 - missing dependency mt-st in bacula-storage-common
Summary: missing dependency mt-st in bacula-storage-common
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bacula
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Josef Ridky
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1356044
TreeView+ depends on / blocked
 
Reported: 2013-02-15 11:59 UTC by Johnny Hughes
Modified: 2017-09-25 08:27 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-25 08:27:59 UTC


Attachments (Terms of Use)
Correction for dependency on mt-st (392 bytes, patch)
2013-03-21 14:52 UTC, Petr Hracek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
CentOS 0005271 None None None Never

Description Johnny Hughes 2013-02-15 11:59:08 UTC
Description of problem:
Package bacula-storage-common contains script /usr/libexec/bacula/mtx-changer which uses the mt command and fails quite ungracefully if it is missing.
The mt command is provided in the mt-st package.
Package bacula-storage-common should therefore require package mt-st.

Steps to Reproduce:
0. uninstall mt-st if present
1. install bacula-storage-common
2. configure autochanger
3. run btape test as recommended in the Bacula documentation

Result: timeout waiting for drive to become ready, although the drive *is* ready

Comment 2 Petr Hracek 2013-03-21 14:52:57 UTC
Created attachment 713913 [details]
Correction for dependency on mt-st

Comment 3 RHEL Product and Program Management 2013-10-13 23:56:27 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 4 Josef Ridky 2017-09-25 08:27:59 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the
Production 3 Phase, Critical impact Security Advisories (RHSAs) and
selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as
they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase
and will be marked as CLOSED/WONTFIX. If this remains a critical
requirement, please contact Red Hat Customer Support to request
a re-evaluation of the issue, citing a clear business justification. Note
that a strong business justification will be required for re-evaluation.
Red Hat Customer Support can be contacted via the Red Hat Customer Portal
at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.