Bug 9119 - All ppp interfaces reported as ppp0 in ifconfig
Summary: All ppp interfaces reported as ppp0 in ifconfig
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-04 14:44 UTC by Clarence Donath
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 16:44:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Clarence Donath 2000-02-04 14:44:11 UTC
No matter which ppp device I bring up (ppp0, ppp1, ppp2, etc.), ifconfig
always reports that the device is ppp0.  Before Red Hat v6.0 ifconfig would
correctly indicate which device was actually up at the time.  Now that
ifconfig always reports ppp0, I cannot tell which device is actually up.
This is essential information.  I can find out which device is up by
looking at the pid in /var/run, but I think ifconfig should correctly
indicate which device is actually up, as it does for eth*, etc.

Comment 1 Nalin Dahyabhai 2000-02-04 16:44:59 UTC
This is normal behavior.  Interface names (as output by ifconfig) are always
numbered sequentially starting at zero.  Your interface comes up as ppp0 because
it is the first ppp interface that is up on the system.  The device name set in
the related ifcfg-pppX file is only used to determine which copy of ppp-watch to
kill in order to bring the interface down.


Note You need to log in before you can comment on or make changes to this bug.