Bug 912005 - Failed to add VM network interface from User Portal
Failed to add VM network interface from User Portal
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.2.0
Unspecified Unspecified
high Severity urgent
: ---
: 3.2.0
Assigned To: Alona Kaplan
Meni Yakove
network
: Regression
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-02-17 02:47 EST by Moti Asayag
Modified: 2016-02-10 14:55 EST (History)
9 users (show)

See Also:
Fixed In Version: sf8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 12137 None None None Never

  None (edit)
Description Moti Asayag 2013-02-17 02:47:41 EST
Description of problem:
Attempt to add VM network interface from User Portal could not complete since the 'OK' button is greyed out.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Login to User Portal
2. Add VM network interface
  
Actual results:
The 'OK' button is greyed out.

Expected results:
'Add VM interface' dialog should be loaded properly.

Additional info:
Bug caused due to NPE within NewVmInterfaceModel.initSelectedNetwork() due to null value for ENGINE_NETWORK_NAME which is retrieved as null from the cache.
Comment 2 Alona Kaplan 2013-02-17 07:43:45 EST
The bug is caused by the fix of https://bugzilla.redhat.com/903287.
The fix was that management network should be the default if it is part of the network list.
To determine whether the network is management a configuration value is used.
The configuration value can't be accessed from user role.

The proposed solution-
If the configuration value of the management network can't be accessed the default network will be the first one in the list (no matter if it is the management or not).
Comment 3 Meni Yakove 2013-02-27 04:30:47 EST
Verified on rhevm-3.2.0-9.el6ev.noarch
Comment 4 Itamar Heim 2013-06-11 05:45:05 EDT
3.2 has been released
Comment 5 Itamar Heim 2013-06-11 05:45:12 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 05:55:49 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.