Bug 912030 - [abrt] eog-3.6.2-1.fc18: get_buddy: Process /usr/bin/eog was killed by signal 6 (SIGABRT)
Summary: [abrt] eog-3.6.2-1.fc18: get_buddy: Process /usr/bin/eog was killed by signal...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cairo
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Benjamin Otte
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7569a5d61abb38e59448a546193...
: 911797 918122 918123 926006 949217 954958 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-17 10:22 UTC by Sam K. Raju
Modified: 2013-06-06 01:42 UTC (History)
10 users (show)

Fixed In Version: cairo-1.12.14-2.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-29 02:56:47 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (85.19 KB, text/plain)
2013-02-17 10:22 UTC, Sam K. Raju
no flags Details
File: cgroup (126 bytes, text/plain)
2013-02-17 10:22 UTC, Sam K. Raju
no flags Details
File: core_backtrace (12.56 KB, text/plain)
2013-02-17 10:22 UTC, Sam K. Raju
no flags Details
File: dso_list (11.47 KB, text/plain)
2013-02-17 10:22 UTC, Sam K. Raju
no flags Details
File: environ (1.42 KB, text/plain)
2013-02-17 10:22 UTC, Sam K. Raju
no flags Details
File: limits (1.29 KB, text/plain)
2013-02-17 10:22 UTC, Sam K. Raju
no flags Details
File: maps (52.26 KB, text/plain)
2013-02-17 10:22 UTC, Sam K. Raju
no flags Details
File: open_fds (515 bytes, text/plain)
2013-02-17 10:23 UTC, Sam K. Raju
no flags Details
File: proc_pid_status (916 bytes, text/plain)
2013-02-17 10:23 UTC, Sam K. Raju
no flags Details
backtrace captured during crash (9.95 KB, text/plain)
2013-03-20 19:39 UTC, Matt Hirsch
no flags Details
backtrace from gthumb (16.31 KB, text/plain)
2013-03-20 19:44 UTC, Matt Hirsch
no flags Details

Description Sam K. Raju 2013-02-17 10:22:36 UTC
Version-Release number of selected component:
eog-3.6.2-1.fc18

Additional info:
backtrace_rating: 4
cmdline:        eog /run/media/sam/3136-6563/DCIM/104___02/IMG_1076.JPG
crash_function: get_buddy
executable:     /usr/bin/eog
kernel:         3.7.6-201.fc18.x86_64
remote_result:  NOTFOUND
uid:            1000
var_log_messages: Feb 17 01:28:56 samkraju abrt[12834]: Saved core dump of pid 12828 (/usr/bin/eog) to /var/spool/abrt/ccpp-2013-02-17-01:28:54-12828 (352555008 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 get_buddy at cairo-mempool.c:160
 #6 merge_buddies at cairo-mempool.c:184
 #7 _cairo_mempool_free at cairo-mempool.c:360
 #8 _cairo_xlib_shm_info_cleanup at cairo-xlib-surface-shm.c:484
 #9 _cairo_xlib_shm_info_create at cairo-xlib-surface-shm.c:633
 #10 _cairo_xlib_shm_surface_create at cairo-xlib-surface-shm.c:822
 #11 _cairo_xlib_surface_create_shm at cairo-xlib-surface-shm.c:1148
 #12 draw_image_boxes at cairo-xlib-render-compositor.c:307
 #13 upload_boxes at cairo-traps-compositor.c:1331
 #14 clip_and_composite_boxes at cairo-traps-compositor.c:1725

Comment 1 Sam K. Raju 2013-02-17 10:22:41 UTC
Created attachment 698479 [details]
File: backtrace

Comment 2 Sam K. Raju 2013-02-17 10:22:43 UTC
Created attachment 698480 [details]
File: cgroup

Comment 3 Sam K. Raju 2013-02-17 10:22:46 UTC
Created attachment 698481 [details]
File: core_backtrace

Comment 4 Sam K. Raju 2013-02-17 10:22:48 UTC
Created attachment 698482 [details]
File: dso_list

Comment 5 Sam K. Raju 2013-02-17 10:22:51 UTC
Created attachment 698483 [details]
File: environ

Comment 6 Sam K. Raju 2013-02-17 10:22:53 UTC
Created attachment 698484 [details]
File: limits

Comment 7 Sam K. Raju 2013-02-17 10:22:56 UTC
Created attachment 698485 [details]
File: maps

Comment 8 Sam K. Raju 2013-02-17 10:23:01 UTC
Created attachment 698486 [details]
File: open_fds

Comment 9 Sam K. Raju 2013-02-17 10:23:03 UTC
Created attachment 698487 [details]
File: proc_pid_status

Comment 10 Kalev Lember 2013-02-17 10:26:16 UTC
Looks like a cairo crash, reassigning.

Comment 11 Kalev Lember 2013-02-17 14:29:37 UTC
*** Bug 911797 has been marked as a duplicate of this bug. ***

Comment 12 Kalev Lember 2013-03-05 14:38:36 UTC
*** Bug 918122 has been marked as a duplicate of this bug. ***

Comment 13 Matt Hirsch 2013-03-05 15:40:28 UTC
FYI this still happens with cairo-1.12.14-1.fc18.x86_64 (Kalev had asked me to report in 911797).

Comment 14 Oleg 2013-03-14 06:05:25 UTC
t issues error with the survey of photographs.

Comment 15 Oleg 2013-03-14 06:06:08 UTC
(In reply to comment #14)
> It issues error with the survey of photographs.

Comment 16 Matt Hirsch 2013-03-20 19:39:31 UTC
Created attachment 713433 [details]
backtrace captured during crash

I managed to catch a backtrace. It looks very similar to the original bug report.

Comment 17 Matt Hirsch 2013-03-20 19:44:35 UTC
Created attachment 713435 [details]
backtrace from gthumb

Comment 18 Brent R Brian 2013-04-15 13:45:14 UTC
Opened a document and clicked the rotate right 90 button.  File was on USB attached memory device (hand scanner Brookstone iConvert)

Comment 19 Chris 2013-05-14 08:41:12 UTC
I want to open a picture with 5.9mb size from an android drive, but it does not work

reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        eog '/run/media/chris/40F1-07D3/DCIM/Camera/2013-05-03 07.34.38.jpg'
core_backtrace: 
crash_function: get_buddy
executable:     /usr/bin/eog
kernel:         3.8.11-200.fc18.i686.PAE
package:        eog-3.6.2-1.fc18
reason:         Process /usr/bin/eog was killed by signal 6 (SIGABRT)
runlevel:       N 5
uid:            500
xsession_errors:

Comment 20 Kalev Lember 2013-05-25 21:41:58 UTC
Cairo appears to have a fix for this in upstream git:

commit 01a8bf01c6508a4fea8d40371c3049e7a2f7908a
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Fri Mar 15 09:08:00 2013 +0000

    mempool: Reduce an assert into an error return for get_buddy()
    
    If we ask for a buddy that is outside of our allocation that is an
    error that should not happen with a power-of-two allocated zone...
    However, since it has been seen in the wild, we can safely return that
    there is no buddy rather than die in a too-late assert.
    
    Reported-by: Anton Eliasson <devel@antoneliasson.se>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>

Comment 21 Kalev Lember 2013-05-25 21:58:30 UTC
*** Bug 926006 has been marked as a duplicate of this bug. ***

Comment 22 Kalev Lember 2013-05-25 21:58:34 UTC
*** Bug 949217 has been marked as a duplicate of this bug. ***

Comment 23 Kalev Lember 2013-05-25 21:59:24 UTC
*** Bug 954958 has been marked as a duplicate of this bug. ***

Comment 24 Fedora Update System 2013-05-25 22:04:10 UTC
cairo-1.12.14-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cairo-1.12.14-2.fc19

Comment 25 Fedora Update System 2013-05-25 22:04:20 UTC
cairo-1.12.14-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/cairo-1.12.14-2.fc18

Comment 26 Kalev Lember 2013-05-25 22:21:44 UTC
*** Bug 918123 has been marked as a duplicate of this bug. ***

Comment 27 Fedora Update System 2013-05-26 17:00:30 UTC
Package cairo-1.12.14-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cairo-1.12.14-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9291/cairo-1.12.14-2.fc19
then log in and leave karma (feedback).

Comment 28 Brent R Brian 2013-05-27 17:11:20 UTC
Is this OK Package cairo-1.12.14-2.fc19 on fc18 system ?

Comment 29 Fedora Update System 2013-05-29 02:56:47 UTC
cairo-1.12.14-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 30 Fedora Update System 2013-06-06 01:42:51 UTC
cairo-1.12.14-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.