Bug 912128 - osad (client) not starting after install (F18)
osad (client) not starting after install (F18)
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.8
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space19
  Show dependency treegraph
 
Reported: 2013-02-17 14:14 EST by Nicholas Nachefski
Modified: 2013-04-04 17:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 13:34:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicholas Nachefski 2013-02-17 14:14:52 EST
After installing the 'osad package' on Fedora 18 (release), it is unable to start citing a problem with the pidfile option.

###It's in a failed state.  It appears that the variable being used to populate --pid-file is being translated literally and not evaluated to the actual value.
# systemctl status osad
osad.service - OSAD daemon
	  Loaded: loaded (/usr/lib/systemd/system/osad.service; enabled)
	  Active: failed (Result: exit-code) since Sun 2013-02-17 13:03:35 CST; 1min 8s ago
	 Process: 3913 ExecStart=/usr/sbin/osad --pid-file $PIDFile (code=exited, status=2)

Feb 17 13:03:35 nn2.nicknach.net systemd[1]: Starting OSAD daemon...
Feb 17 13:03:35 nn2.nicknach.net systemd[1]: Started OSAD daemon.
Feb 17 13:03:35 nn2.nicknach.net osad[3913]: Usage: osad [options]
Feb 17 13:03:35 nn2.nicknach.net osad[3913]: osad: error: --pid-file option requires an argument
Feb 17 13:03:35 nn2.nicknach.net systemd[1]: osad.service: main process exited, code=exited, status=2/INVALIDARGUMENT
Feb 17 13:03:35 nn2.nicknach.net systemd[1]: Unit osad.service entered failed state

###Version info
[root@nn2 ~]# rpm -q osad
osad-5.11.10-1.fc17.noarch


###modify the init script and switch the variable with the actual value, reload the script and then start
[root@nn2 ~]# vi /usr/lib/systemd/system/osad.service
[root@nn2 ~]# systemctl --system daemon-reload
[root@nn2 ~]# systemctl start osad

### it starts and start now
[root@nn2 ~]# systemctl status osad
osad.service - OSAD daemon
	  Loaded: loaded (/usr/lib/systemd/system/osad.service; enabled)
	  Active: active (running) since Sun 2013-02-17 13:07:59 CST; 4s ago
	Main PID: 4023 (osad)
	  CGroup: name=systemd:/system/osad.service
		  └─4023 /usr/bin/python /usr/sbin/osad --pid-file /var/run/osad.pid

Feb 17 13:07:59 nn2.nicknach.net systemd[1]: Starting OSAD daemon...
Feb 17 13:07:59 nn2.nicknach.net systemd[1]: Started OSAD daemon.
Comment 1 Jan Pazdziora 2013-02-20 13:24:59 EST
Fixed in Spacewalk master, e7be1ebf4d8d5a4835d1b0c97158b3805ad24ab3.
Comment 2 Stephen Herr 2013-03-01 12:06:46 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 3 Stephen Herr 2013-03-06 13:34:07 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19
Comment 4 timbrammer910 2013-04-04 17:11:37 EDT
Stephen,

Using the osad package included with 1.9 - osad-5.11.18-1.fc18 seems to also have issues.

systemd seems to think the service is masked, I see no symbolic links in /usr/lib/systemd/system/ /lib/systemd/system/ or /etc/systemd/system.

Is this just an issue with my configuration?

Note You need to log in before you can comment on or make changes to this bug.