Bug 91213 - (TUX)Tux Ftp server fails PASS handshake with apt-get
(TUX)Tux Ftp server fails PASS handshake with apt-get
Status: CLOSED DUPLICATE of bug 90338
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ingo Molnar
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-19 19:26 EDT by John Bass
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Bass 2003-05-19 19:26:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
apt-get passes a long password following a successful anonymous login
which fail .... hand testing, show that shorter passwords work. Basic
testing with lftp client pretty much works otherwise. Trying to do
an ftp RH9 install from the tux ftp server also fails, not sure why.


[root@fastbox root]# apt-get update
Err ftp://cwx.net redhat/8.0/en/i386 release
  PASS failed, server said: Unknown command.



16:58:01.203043 fastbox.dmsd.com.3717 > cwx.net.ftp: 
0x0000   4500 0044 e16a 4000 4006 d2e6 c05c 6307        E..D.j@.@....\c.
0x0010   d811 8aed 0e85 0015 4701 0f6a c33c 9831        ........G..j.<.1
0x0020   8018 16d0 36ea 0000 0101 080a 0a24 ee35        ....6........$.5
0x0030   00a9 6135 5553 4552 2061 6e6f 6e79 6d6f        ..a5USER.anonymo
0x0040   7573 0d0a                                      us..
16:58:01.210872 cwx.net.ftp > fastbox.dmsd.com.3717:
0x0000   4500 004d f935 4000 3f06 bc12 d811 8aed        E..M.5@.?.......
0x0010   c05c 6307 0015 0e85 c33c 9831 4701 0f7a        .\c......<.1G..z
0x0020   8018 16a0 a597 0000 0101 080a 00a9 6137        ..............a7
0x0030   0a24 ee35 3233 3020 5455 5820 4775 6573        .$.5230.TUX.Gues
0x0040   7420 6c6f 6769 6e20 6f6b 2e0d 0a               t.login.ok...
16:58:01.211647 fastbox.dmsd.com.3717 > cwx.net.ftp:
0x0000   4500 005c e16b 4000 4006 d2cd c05c 6307        E..\.k@.@....\c.
0x0010   d811 8aed 0e85 0015 4701 0f7a c33c 984a        ........G..z.<.J
0x0020   8018 16d0 abaa 0000 0101 080a 0a24 ee3a        .............$.:
0x0030   00a9 6137 5041 5353 2061 7074 5f67 6574        ..a7PASS.apt_get
0x0040   5f66 7470 5f32 2e31 4064 6562 6961 6e2e        _ftp_2.1@debian.
0x0050   6c69 6e75 782e 7573 6572 0d0a                  linux.user..
16:58:01.217955 cwx.net.ftp > fastbox.dmsd.com.
0x0000   4500 004a f936 4000 3f06 bc14 d811 8aed        E..J.6@.?.......
0x0010   c05c 6307 0015 0e85 c33c 984a 4701 0fa2        .\c......<.JG...
0x0020   8019 16a0 174e 0000 0101 080a 00a9 6138        .....N........a8
0x0030   0a24 ee3a 3530 3020 556e 6b6e 6f77 6e20        .$.:500.Unknown.
0x0040   636f 6d6d 616e 642e 0d0a                       command...



[root@fastbox root]# telnet cwx.net 21
Trying 216.17.138.237...
Connected to cwx.net.
Escape character is '^]'.
220 Linux 2.4 TUX 2.0 FTP server welcomes you!
USER anonymous
230 TUX Guest login ok.
PASS jbass@dmsd.com
230 TUX Guest login ok.

500 Unknown command.
Connection closed by foreign host.
[root@fastbox root]# telnet cwx.net 21
Trying 216.17.138.237...
Connected to cwx.net.
Escape character is '^]'.
220 Linux 2.4 TUX 2.0 FTP server welcomes you!
USER anonymous
230 TUX Guest login ok.
PASS apt_get_ftp_2.1@debian.linux.user
500 Unknown command.
Connection closed by foreign host.




using the tux ftp 


Version-Release number of selected component (if applicable):
kernel-2.4.20-13.9

How reproducible:
Always

Steps to Reproduce:
1.see telnet to port 21 sessions above
2.
3.
    

Additional info:
Comment 1 Alan Cox 2003-06-09 10:34:22 EDT

*** This bug has been marked as a duplicate of 90338 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:53:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.