Bug 912165 - [kernel] dnf distro-sync and the kernel package
[kernel] dnf distro-sync and the kernel package
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
: 920370 (view as bug list)
Depends On: 905209
Blocks: 871892
  Show dependency treegraph
 
Reported: 2013-02-17 20:32 EST by Heldwin
Modified: 2014-09-30 19:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-05 01:46:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heldwin 2013-02-17 20:32:49 EST
Description of problem:
dnf distro-sync doesn't work the same as yum.

In the last testing, it tries to pull an old kernel.

Version-Release number of selected component (if applicable):
dnf-0.2.21-1.git050524e.fc18.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf distro-sync
2.
3.
  
Actual results:

Installing:
 kernel         x86_64      3.6.10-4.fc18              fedora     27 M
 kernel-devel   x86_64      3.6.10-4.fc18              fedora    7.7 M
Downgrading:
 dnf            noarch      0.2.20-1.gitdec970f.fc18   updates   497 k
 hawkey         x86_64      0.3.6-1.gitc8365fa.fc18    updates    46 k
 python-hawkey  x86_64      0.3.6-1.gitc8365fa.fc18    updates    40 k


Expected results:

Downgrading:
 dnf           noarch       0.2.20-1.gitdec970f.fc18   updates   497 k
 hawkey        x86_64       0.3.6-1.gitc8365fa.fc18    updates    46 k
 python-hawkey x86_64       0.3.6-1.gitc8365fa.fc18    updates    40 k

Additional info:

kernel installed  3.7.5-201, 3.7.6-201, 3.7.7-201
Comment 1 Ales Kozumplik 2013-02-18 06:29:36 EST
Hello,

the support for installonly packages (such as kernel) in DNF is not in a good shape yet and this bug revealed yet another issue. Thanks for reporting.
Comment 2 benoît barthés 2013-03-12 04:05:27 EDT
*** Bug 920370 has been marked as a duplicate of this bug. ***
Comment 3 Michael Schröder 2013-05-28 08:22:48 EDT
Ales, please provide a solver testcase ;)
Comment 4 Ales Kozumplik 2013-05-29 03:29:54 EDT
I know I know. My plan is to fix the number-of-installed-kernels bug and then try to reproduce it in DNF. Who knows maybe it's gone now with all the libsolv fixes.
Comment 5 Ales Kozumplik 2013-12-04 07:46:38 EST
Hello, can this still be reproduced with dnf-0.4.9? Several installonly fixes went in in the meantime.
Comment 6 Heldwin 2013-12-04 08:07:50 EST
Hello,

The problem is I am now on F20, and didn't check dnf too often.

With dnf 0.4.9-1.fc20, if I try with the deactivation of updates-testing made by the package fedora-release-20-1 (and manual reactivation after that), I get in a distro-sync loop with a switch of repo fedora/updates-testing, and can test a little dnf.

So far, it doesn't seem to do that for this version of dnf.
can test on f19 also.
Comment 7 Ales Kozumplik 2013-12-04 09:08:12 EST
> With dnf 0.4.9-1.fc20, if I try with the deactivation of updates-testing
> made by the package fedora-release-20-1 (and manual reactivation after
> that), I get in a distro-sync loop with a switch of repo
> fedora/updates-testing, and can test a little dnf.

I am not sure if I follow here: what do you mean by 'distro-sync loop'?
Comment 8 Heldwin 2013-12-04 21:52:14 EST
I mean by activating/deactivating the fedora-updates-testing repo, maybe calling it a loop isn't appropriate :) 

* distro-sync on the fedora repo, that do about 149 downgrades because I was on updates-testing, and deleteting the last kernel after that (I am on the previous one)
* getting back to the updates-testing repo using distro-sync
* doing the same with yum to compare

(just doing it as a test on 1 machine, fully backuped)

But it doesn't try to grab an old kernel anymore (deleting or not the last kernel)

At this time, it also seems to have the exact same number of packages to downgrade/upgrade between yum and dnf
Comment 9 Ales Kozumplik 2013-12-05 01:46:15 EST
(In reply to Heldwin from comment #8)
> 
> At this time, it also seems to have the exact same number of packages to
> downgrade/upgrade between yum and dnf

DNF and yum use different depsolvers so sometimes DNF offers different (some would say more correct) results. That is not a bug unless shown specifically that a wrong package was distro-synced or that DNF refuses to distro-sync a certain package.(In reply to Heldwin from comment #8)

> But it doesn't try to grab an old kernel anymore (deleting or not the last
> kernel)

I will close this bug per this comment. If DNF distro-sync doesn't work for you the way it should please reopen this bug, with debugdata/ attached.

[1] http://dnf.baseurl.org/2013/11/25/reporting-depsolving-bugs/

Note You need to log in before you can comment on or make changes to this bug.