Bug 912210 - Got python call trace when creating pscsi storage object in targetcli.
Got python call trace when creating pscsi storage object in targetcli.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fcoe-target-utils (Show other bugs)
6.4
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Andy Grover
Bruno Goncalves
: Regression, ZStream
Depends On:
Blocks: 883516 917478
  Show dependency treegraph
 
Reported: 2013-02-18 01:18 EST by Gris Ge
Modified: 2013-11-21 17:27 EST (History)
1 user (show)

See Also:
Fixed In Version: python-rtslib-2.1.fb21-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:27:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2013-02-18 01:18:40 EST
Description of problem:
=======
/> /backstores/pscsi create tmp_disk /dev/sdk 
Note: block backstore recommended for SCSI block devices
Traceback (most recent call last):                      
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 990, in run_interactive                        
    self._cli_loop()                                                                                                
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 813, in _cli_loop                              
    self.run_cmdline(cmdline)                                                                                       
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 934, in run_cmdline                            
    self._execute_command(path, command, pparams, kparams)                                                          
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 909, in _execute_command                       
    result = target.execute_command(command, pparams, kparams)                                                      
  File "/usr/lib/python2.6/site-packages/targetcli/ui_node.py", line 84, in execute_command
    pparams, kparams)
  File "/usr/lib/python2.6/site-packages/configshell/node.py", line 1405, in execute_command
    result = method(*pparams, **kparams)
  File "/usr/lib/python2.6/site-packages/targetcli/ui_backstore.py", line 185, in ui_command_create
    so = PSCSIStorageObject(name, dev)
  File "/usr/lib/python2.6/site-packages/rtslib/tcm.py", line 264, in __init__
    self._configure(dev)
  File "/usr/lib/python2.6/site-packages/rtslib/tcm.py", line 273, in _configure
    parent_hostid = self.backstore.index
AttributeError: 'PSCSIStorageObject' object has no attribute 'backstore'
=======

Version-Release number of selected component (if applicable):
fcoe-target-utils-2.0rc1.fb16-3.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. targetcli /backstores/pscsi create tmp_disk /dev/sdk 
2.
3.
  
Actual results:
python call trace

Expected results:
no python call trace

Additional info:

Does "pscsi" not support anymore? If so, please remove it warn user to use block storage object.
Comment 6 Andy Grover 2013-03-01 13:36:25 EST
Note: bug is/was in python-rtslib pkg, which is used by targetcli.
Comment 9 Bruno Goncalves 2013-08-14 07:52:42 EDT
Verified on rpm -q python-rtslib
python-rtslib-2.1.fb21-3.el6_4.noarch


# targetcli /backstores/pscsi create tmp_disk /dev/sdb
Note: block backstore recommended for SCSI block devices
Created pscsi storage object tmp_disk using /dev/sdb


# targetcli ls
o- / ......................................................................................................................... [...]
  o- backstores .............................................................................................................. [...]
  | o- block .................................................................................................... [0 Storage Object]
  | o- fileio ................................................................................................... [0 Storage Object]
  | o- pscsi .................................................................................................... [1 Storage Object]
  |   o- tmp_disk ........................................................................................... [/dev/sdb deactivated]
  o- loopback .......................................................................................................... [0 Targets]



targetcli saveconfig
Configuration saved to /etc/target/saveconfig.json

# service fcoe-target restart
   Deactivating FCoE Target... done
   Unloading FCoE Target modules... done
   Unmounting configfs... done
[  OK  ]
Starting FCoE Target: 
   Loading modules... done
   Mounting configfs... done
   Applying saved config... done
[  OK  ]

# targetcli ls
o- / ......................................................................................................................... [...]
  o- backstores .............................................................................................................. [...]
  | o- block .................................................................................................... [0 Storage Object]
  | o- fileio ................................................................................................... [0 Storage Object]
  | o- pscsi .................................................................................................... [1 Storage Object]
  |   o- tmp_disk ........................................................................................... [/dev/sdb deactivated]
  o- loopback .......................................................................................................... [0 Targets]
Comment 10 errata-xmlrpc 2013-11-21 17:27:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1683.html

Note You need to log in before you can comment on or make changes to this bug.