This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 912361 - tomahawk is FTBFS on ARM
tomahawk is FTBFS on ARM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tomahawk (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-02-18 09:18 EST by Peter Robinson
Modified: 2013-02-18 10:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 10:08:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2013-02-18 09:18:20 EST
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1446868

It's FTBFS on ARM due to the tomahawk_crash_reporter is missing from the build. I'm not sure if that's because tomahawk_crash_reporter isn't supported on ARM or because it's missing a buildrequires that's pulled in via something else on x86. It would be good to either get the file excluded on ARM if it's not supported, or the build fixed if it's something else.
Comment 1 Rex Dieter 2013-02-18 09:59:15 EST
Indeed, upstream disables this purposely on arm,

IF( CMAKE_SYSTEM_PROCESSOR MATCHES "arm" )
    message(STATUS "Build of breakpad library disabled on this platform.")
    SET(WITH_BREAKPAD OFF)
    SET(WITH_CRASHREPORTER OFF)
ENDIF()

I'll fix this up.
Comment 2 Rex Dieter 2013-02-18 10:08:29 EST
%changelog
* Mon Feb 18 2013 Rex Dieter <rdieter@fedoraproject.org> 0.6.0-3
- tomahawk is FTBFS on ARM (#912361)

Note You need to log in before you can comment on or make changes to this bug.