Bug 912393 - rhnpush fails to build on F19 due pylint erros
rhnpush fails to build on F19 due pylint erros
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.9
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: space19
  Show dependency treegraph
 
Reported: 2013-02-18 10:28 EST by Miroslav Suchý
Modified: 2013-03-06 13:34 EST (History)
0 users

See Also:
Fixed In Version: rhnpush-5.5.60-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 13:34:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2013-02-18 10:28:24 EST
Description of problem:
rhnpush fails to build on F19
http://koji.fedoraproject.org/koji/taskinfo?taskID=5024704

+ spacewalk-pylint /builddir/build/BUILDROOT/rhnpush-5.5.59-1.fc19.noarch/usr/share/rhn
************* Module archive
E1101:329,4:_my_popen: Instance of 'Popen' has no 'stdin' member
E1101:333,38:_my_popen: Instance of 'Popen' has no 'stdout' member
E1101:333,52:_my_popen: Instance of 'Popen' has no 'stderr' member
E1101:333,74:_my_popen: Instance of 'Popen' has no 'stdout' member
E1101:333,88:_my_popen: Instance of 'Popen' has no 'stderr' member
E1101:335,19:_my_popen: Instance of 'Popen' has no 'stdout' member
E1101:336,19:_my_popen: Instance of 'Popen' has no 'stderr' member
E1101:342,13:_my_popen: Instance of 'Popen' has no 'wait' member
************* Module solaris2mpm
W1401: 39,0: Anomalous backslash in string: '\('. String constant might be missing an r prefix.
W1401: 39,0: Anomalous backslash in string: '\)'. String constant might be missing an r prefix.
W1401: 40,0: Anomalous backslash in string: '\S'. String constant might be missing an r prefix.
W1401: 40,0: Anomalous backslash in string: '\s'. String constant might be missing an r prefix.
W1401: 41,0: Anomalous backslash in string: '\S'. String constant might be missing an r prefix.
W1401: 41,0: Anomalous backslash in string: '\s'. String constant might be missing an r prefix.
W1401: 42,0: Anomalous backslash in string: '\?'. String constant might be missing an r prefix.
W1401: 42,0: Anomalous backslash in string: '\*'. String constant might be missing an r prefix.
W1401: 42,0: Anomalous backslash in string: '\|'. String constant might be missing an r prefix.
W1401: 42,0: Anomalous backslash in string: '\~'. String constant might be missing an r prefix.
W1401: 42,0: Anomalous backslash in string: '\$'. String constant might be missing an r prefix.
W1401: 42,0: Anomalous backslash in string: '\('. String constant might be missing an r prefix.
W1401: 42,0: Anomalous backslash in string: '\)'. String constant might be missing an r prefix.
W1401: 42,0: Anomalous backslash in string: '\]'. String constant might be missing an r prefix.
W1401: 42,0: Anomalous backslash in string: '\s'. String constant might be missing an r prefix.
************* Module rhnpush_config
R0924: 28,0:rhnpushConfigParser: Badly implemented Container, implements __getitem__ but not __delitem__, __len__, __setitem__
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.qqAXfy (%check)
    Bad exit status from /var/tmp/rpm-tmp.qqAXfy (%check)


Version-Release number of selected component (if applicable):
rhnpush-5.5.59-1

How reproducible:
deterministic

Steps to Reproduce:
1.koji buiild --scratch f19 /tmp/tito-build/rhnpush-5.5.59-1.fc18.src.rpm
  
Actual results:
fail

Expected results:
success
Comment 1 Michael Mráka 2013-02-28 03:35:31 EST
Fixed in Spacewalk master by

commit e1f5b4d232fa9db7467afeb726f908c4d1348a8e
    silence pylint warnings
    R0924: 28,0:rhnpushConfigParser: Badly implemented Container, implements __getitem__ but not __delitem__, __len__, __setitem__

commit abcbb10e30ce60318f4a7dd150078ffbd475f58f
    disable false positive warnings
    fixing
    E1101:175,4:rhn_popen: Instance of 'Popen' has no 'stdin' member
    E1101:182,20:rhn_popen: Instance of 'Popen' has no 'stdout' member
    E1101:182,43:rhn_popen: Instance of 'Popen' has no 'stderr' member
    E1101:188,17:rhn_popen: Instance of 'Popen' has no 'poll' member

commit 82b744a816c377eaf9f7e2674b38bdea149a3cba
    fixed pylint warnings
    W1401: 39,0: Anomalous backslash in string: '\('. String constant might be missing an r prefix.
    W1401: 39,0: Anomalous backslash in string: '\)'. String constant might be missing an r prefix.
    W1401: 40,0: Anomalous backslash in string: '\S'. String constant might be missing an r prefix.
    W1401: 40,0: Anomalous backslash in string: '\s'. String constant might be missing an r prefix.
    W1401: 41,0: Anomalous backslash in string: '\S'. String constant might be missing an r prefix.
    ...
Comment 2 Stephen Herr 2013-03-01 12:07:10 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 3 Stephen Herr 2013-03-06 13:34:35 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.