Bug 912398 - Cannot install mozilla open web apps
Cannot install mozilla open web apps
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-18 10:35 EST by Davi
Modified: 2013-03-13 08:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 08:15:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 762833 None None None Never

  None (edit)
Description Davi 2013-02-18 10:35:03 EST
Description of problem:

When I try to install an app from https://apps.mozillalabs.com/appdir/, I get an error dialog "Error in installation: [object DOMError]". In the error console the following entry appears:

Hora: 18-02-2013 12:28:02
Erro: Error installing app: [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIFile.copyTo]"  nsresult: "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)"  location: "JS frame :: resource://gre/modules/WebappsInstaller.jsm :: <TOP_LEVEL> :: line 213"  data: no]
Arquivo-fonte: resource://gre/modules/WebappsInstaller.jsm
Linha: 39


When I try to install an app from https://marketplace.firefox.com/, the installation fails silently. The exact same error entry appears in the error console:

Hora: 18-02-2013 12:29:45
Erro: Error installing app: [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIFile.copyTo]"  nsresult: "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)"  location: "JS frame :: resource://gre/modules/WebappsInstaller.jsm :: <TOP_LEVEL> :: line 213"  data: no]
Arquivo-fonte: resource://gre/modules/WebappsInstaller.jsm
Linha: 39

Version-Release number of selected component (if applicable):
firefox-18.0.2-1.fc18.x86_64

How reproducible:
Every time I try to install an app the error entry is added to the console and the installation fails.

Steps to Reproduce:
1. go to either https://apps.mozillalabs.com/appdir/ or https://marketplace.firefox.com/
2. try to install a desktop compatible app (e.g. https://marketplace.firefox.com/app/wikipedia/?src=mkt-home)
  
Actual results:
The application is not installed (no installation success feedback, no application .desktop file created and no other visible changes to the system)

Expected results:
The application should be installed and available from the overview.

Additional info:
Comment 1 Jan Horak 2013-02-21 05:40:22 EST
Looks like bug in upstream:
https://bugzilla.mozilla.org/show_bug.cgi?id=762833
Comment 2 Jan Horak 2013-03-13 08:15:56 EDT
Thanks for bug report. We're going to track this issue on upstream.

Note You need to log in before you can comment on or make changes to this bug.