Bug 9124 - halt, reboot use $DISPLAY
Summary: halt, reboot use $DISPLAY
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: SysVinit   
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-04 16:33 UTC by Karl Berry
Modified: 2014-03-17 02:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 06:01:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karl Berry 2000-02-04 16:33:29 UTC
(this is not an install problem but i don't know the proper component.)

halt and shutdown try to do X things with $DISPLAY is set.
this is really painful since on server machines, $DISPLAY
might well be set (from a login that propagated it or something)
but the machine is in trouble -- that's why you're trying to reboot it.

this is unlike every other unix i know of, and it seems undesirable to me.
i understand that for novice users, in x, it may be useful.
so maybe there should be an alias or an option, but as default
behavior ... argh.

thanks.

Comment 1 Bill Nottingham 2000-02-05 01:29:59 UTC
You're probably noticing them when run through the userhelper
program; is /usr/bin before /usr/sbin in root's path in
your case?


Note You need to log in before you can comment on or make changes to this bug.