Bug 912403 - brew/rhpkg doesn't support collections
Summary: brew/rhpkg doesn't support collections
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpkg
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Pavol Babinčák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 844079 864736 969460 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-18 15:52 UTC by Marcela Mašláňová
Modified: 2014-10-06 15:09 UTC (History)
15 users (show)

(edit)
Clone Of:
: 1078947 (view as bug list)
(edit)
Last Closed: 2014-06-10 07:34:29 UTC


Attachments (Terms of Use)

Description Marcela Mašláňová 2013-02-18 15:52:55 UTC
It would be appreciated if rhpkg could set up environment for build of a collection. 
For example, if you have scl-utils installed on a system you issue `rhpkg build`, the giturl it submits will be wrong, because it'll expand the %{scl} macro.

I guess warnings would be nice or something like rhpkg build --scl, which would switch on more checks. I'm not sure what should be improved, because I'm not aware of functionality inside of rhpkg. It might be better if someone from release engineering improve it for regular developers.

Comment 1 Lubos Kocman 2013-06-21 07:22:59 UTC
*** Bug 905521 has been marked as a duplicate of this bug. ***

Comment 2 Josef Stribny 2013-11-14 15:29:21 UTC
This bug should be definitely addressed soon.

Everyone who's building software collections has to switch to brew at some point, because the builds would appear as conflicting (they won't conflict if one's lucky). If software collection is such an interesting and valuable product, we should be able to build it using official Package Source Control Tool such as rhpkg.

It would also save me and Lubos from rel-eng some time debugging what might be wrong when it's already a known issue for almost 11 months (and for others that come across this for the first time).

Comment 3 Bohuslav "Slavek" Kabrda 2014-03-20 11:59:23 UTC
We've just hit this again with RHSCL 1.1 python27 collection - python27-python NVR is the same as RHEL 7 python NVR, so we keep getting

Could not execute build: python-2.7.5-12.el7 has already been built

which is plainly wrong. Pavol, could you please do something about it? This has been reported for more than a year now.

Comment 4 Pavol Babinčák 2014-03-20 15:19:10 UTC
(In reply to Bohuslav "Slavek" Kabrda from comment #3)
> We've just hit this again with RHSCL 1.1 python27 collection -
> python27-python NVR is the same as RHEL 7 python NVR, so we keep getting
> 
> Could not execute build: python-2.7.5-12.el7 has already been built
> 
> which is plainly wrong. Pavol, could you please do something about it? This
> has been reported for more than a year now.
This is different problem and will be addressed in Bug 1078947.

Comment 5 Pavol Babinčák 2014-03-20 15:22:02 UTC
Fix will be made in underlying library - rpkg. giturl will be build from git remote from current tracking branch.

Comment 6 Pavol Babinčák 2014-03-25 13:04:15 UTC
*** Bug 969460 has been marked as a duplicate of this bug. ***

Comment 7 Pavol Babinčák 2014-06-13 13:26:49 UTC
*** Bug 844079 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2014-07-30 11:55:49 UTC
fedpkg-1.18-1.fc19,rpkg-1.26-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedpkg-1.18-1.fc19,rpkg-1.26-1.fc19

Comment 9 Fedora Update System 2014-07-30 12:00:55 UTC
fedpkg-1.18-1.fc20,rpkg-1.26-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedpkg-1.18-1.fc20,rpkg-1.26-1.fc20

Comment 10 Fedora Update System 2014-07-30 12:20:07 UTC
fedpkg-1.18-1.el6,rpkg-1.26-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedpkg-1.18-1.el6,rpkg-1.26-1.el6

Comment 11 Fedora Update System 2014-08-08 08:40:10 UTC
fedpkg-1.18-1.fc20, rpkg-1.26-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2014-08-15 02:54:48 UTC
fedpkg-1.18-1.fc19, rpkg-1.26-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2014-08-15 18:59:32 UTC
fedpkg-1.18-1.el6, rpkg-1.26-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Pavol Babinčák 2014-10-06 15:09:10 UTC
*** Bug 864736 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.