Bug 912498 - When listing multiple operations pcs should print one per line
Summary: When listing multiple operations pcs should print one per line
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs
Version: 6.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-18 20:07 UTC by Chris Feist
Modified: 2013-11-21 11:51 UTC (History)
6 users (show)

Fixed In Version: pcs-0.9.64-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: When a resource had multiple operations they were all displayed on the same line. Consequence: It could be difficult to see all operations a particular resource had Fix: Each resource operation is now displayed on it's own line. Result: It's easier to view resources with multiple operations.
Clone Of:
Environment:
Last Closed: 2013-11-21 11:51:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1633 normal SHIPPED_LIVE pcs bug fix and enhancement update 2013-11-20 21:53:48 UTC

Description Chris Feist 2013-02-18 20:07:44 UTC
Description of problem:
It's difficult to view the operations that are configured for a resource if there is more than one

Version-Release number of selected component (if applicable):
pcs-0.9.26-10.el6.noarch

How reproducible:
Always


[root@ask-03 ~]# pcs -f test  resource create test IPaddr2
[root@ask-03 ~]# pcs -f test resource add_operation IPaddr2 start interval="0" timeout="20s"
Unable to find resource: IPaddr2
[root@ask-03 ~]# pcs -f test resource add_operation test start interval="0" timeout="20s"
[root@ask-03 ~]# pcs -f test resource add_operation test stop interval="0" timeout="20s"
[root@ask-03 ~]# pcs -f test resource add_operation test monitor interval="0" timeout="20s"
[root@ask-03 ~]# pcs -f test resource
 test	(ocf::heartbeat:IPaddr2):	Stopped 
[root@ask-03 ~]# pcs -f test resource --all
 Resource: test (provider=heartbeat type=IPaddr2 class=ocf)
  Operations: start interval=0 timeout=20s stop interval=0 timeout=20s monitor interval=0 timeout=20s

Output should looks something like this:
[root@ask-03 ~]# pcs -f test resource --all
 Resource: test (provider=heartbeat type=IPaddr2 class=ocf)
  Operations: start interval=0 timeout=20s
              stop interval=0 timeout=20s
              monitor interval=0 timeout=20s

Comment 8 Chris Feist 2013-08-13 21:21:02 UTC
[root@ask-02 ~]# rpm -q pcs
pcs-0.9.64-1.el6.noarch
[root@ask-02 ~]# pcs -f test.xml resource create Test Dummy op monitor interval=30s op monitor interval=31s
[root@ask-02 ~]# pcs -f test.xml resource show Test
 Resource: Test (class=ocf provider=heartbeat type=Dummy)
  Operations: monitor interval=30s (Test-monitor-interval-30s)
              monitor interval=31s (Test-monitor-interval-31s)

Comment 11 errata-xmlrpc 2013-11-21 11:51:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1633.html


Note You need to log in before you can comment on or make changes to this bug.