Bug 9125 - ps auxww does not guarantee widest
ps auxww does not guarantee widest
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-04 11:35 EST by Karl Berry
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 16:44:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl Berry 2000-02-04 11:35:26 EST
the man page for ps says that ww does not guarantee you the entire
argv[0], breaking scripts which assume that, since every other
unix implemented it that way.  (if they have bsd ps at all, that is.)
in fact, no amount of w's guarantee it, which seems pretty
problematic/undesirable.

thanks.
Comment 1 Riley H Williams 2000-02-04 12:33:59 EST
I've just tried this on Solaris, and discover that it rejects the command as
being in error:

 Q> raven% ps auxww
 Q> usage: ps [ -aAdeflcjLPy ] [ -o format ] [ -t termlist ]
 Q>         [ -u userlist ] [ -U userlist ] [ -G grouplist ]
 Q>         [ -p proclist ] [ -g pgrplist ] [ -s sidlist ]
 Q>   'format' is one or more of:
 Q>         user ruser group rgroup uid ruid gid rgid pid ppid pgid sid
 Q>         pri opri pcpu pmem vsz rss osz nice class time etime stime
 Q>         f s c lwp nlwp psr tty addr wchan fname comm args
 Q> raven%

I would therefore have to assume that this bug report is faulty...
Comment 2 Nalin Dahyabhai 2000-02-04 16:44:59 EST
Solaris does not have a BSD-style ps command, except possibly in /usr/ucb.
Comment 3 Michael K. Johnson 2000-07-31 16:14:21 EDT
"BSD-like" arguments in procps 2.0.x are retained primarily for compatibility
with
the old version of procps in which they were the only form of options, and so
their semantics will not be changed.

SysV options are the only options that are remotely close to portable between
different versions of ps.
Comment 4 Karl Berry 2000-08-01 11:15:58 EDT
look, my original point has apparently been lost.  nothing has been resolved.

the point is, there should be a way to linux to show the process table with all
arguments to the processes.  according to the man page, you would have to give
an infinite number of w's to ps to guarantee it.  if there's another way to get
the same effect, the man page should state it.  however, i think it would be
better for ww to have the effect.
Comment 5 Philip Rowlands 2000-10-29 09:39:32 EST
I suspect that the manual might be wrong. I cannot confirm this because the
source is rather dense, and it's not obvious where the "w" option is parsed.
However, tests with RH6.2 show that "ww" will give as many lines of output as
required.

Compare the following:
% sort /dev/zero `seq 1000` & ; ps aux
% sort /dev/zero `seq 1000` & ; ps auxw
% sort /dev/zero `seq 1000` & ; ps auxww
(expect sort to crash with "memory exhausted")

Note You need to log in before you can comment on or make changes to this bug.