Bug 912664 - eclipse-swt should put swt.jar into /usr/lib/java even on 64 bit systems.
Summary: eclipse-swt should put swt.jar into /usr/lib/java even on 64 bit systems.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krzysztof Daniel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-19 11:03 UTC by Severin Gehwolf
Modified: 2014-01-13 00:27 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-19 20:03:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Severin Gehwolf 2013-02-19 11:03:03 UTC
Description of problem:
Java libraries which depend on swt.jar, fail to build from source if build-classpath swt is used in the spec file. Example:
http://kojipkgs.fedoraproject.org//work/tasks/9102/4989102/build.log

Version-Release number of selected component (if applicable):
latest rawhide version.

How reproducible:
Always.

Steps to Reproduce:
1. try to mock-build jfreechart. The build of the experimental swt bits is failing.
  
Actual results:
build-classpath swt
/usr/bin/build-classpath: error: Could not find swt Java extension for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found

Expected results:
build-classpath swt
/usr/lib/java/swt.jar

Additional info:
According to mizdebsk:
quote from java guidelines: "%{_jnidir} usually expands into %{_prefix}/lib/java. %{_prefix}/lib64/java will cease its existence and will be decomissioned"

looks like a bug in elclipse
eclipse puts stuff to /usr/lib64, but /usr/lib should be used, even on 64-bit systems

Comment 1 Severin Gehwolf 2013-02-19 12:53:20 UTC
For reference see bug 665576

Comment 2 Mikolaj Izdebski 2013-02-19 13:48:33 UTC
Java packages are currently exempt from multilib, as per FESCO exception [1]. According to current JNI guidelines [2] native code should always be placed in /usr/lib, not %_libdir (%_libdir can be either /usr/lib or /usr/lib64).

[1] https://fedorahosted.org/fesco/ticket/961
[2] http://fedoraproject.org/wiki/Packaging:Java#Packaging_JAR_files_that_use_JNI

Comment 3 Fedora Update System 2013-02-20 11:17:59 UTC
eclipse-4.2.2-0.10.git20121217.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eclipse-4.2.2-0.10.git20121217.fc18

Comment 4 Fedora Update System 2013-02-21 05:45:33 UTC
Package eclipse-4.2.2-0.10.git20121217.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-4.2.2-0.10.git20121217.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2796/eclipse-4.2.2-0.10.git20121217.fc18
then log in and leave karma (feedback).

Comment 5 Edward Sheldrake 2013-02-22 07:09:53 UTC
In eclipse-swt-4.2.2-0.10.git20121217.fc18.x86_64 /usr/lib/java/swt.jar is a broken symlink:
/usr/lib/java/swt.jar -> ../eclipse/swt.jar

Comment 6 Fedora Update System 2013-02-27 18:44:44 UTC
eclipse-4.2.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eclipse-4.2.2-2.fc18

Comment 7 Fedora Update System 2013-03-04 09:09:33 UTC
eclipse-4.2.2-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eclipse-4.2.2-3.fc18

Comment 8 Fedora Update System 2013-03-15 11:52:07 UTC
eclipse-4.2.2-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eclipse-4.2.2-5.fc18

Comment 9 Fedora Update System 2013-03-19 20:03:39 UTC
eclipse-4.2.2-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.