Bug 912857 - ICE when building arm kernel with gcc 4.8
ICE when building arm kernel with gcc 4.8
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-02-19 16:03 EST by Peter Robinson
Modified: 2013-02-20 04:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-20 04:46:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output from failed build (1.05 MB, text/plain)
2013-02-19 16:38 EST, Peter Robinson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 56405 None None None Never

  None (edit)
Description Peter Robinson 2013-02-19 16:03:43 EST
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1450976

The same kernel builds fine on F18 as a scrtch build@
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1450976

It looks like this might be related 
gcc.gnu.org/bugzilla/show_bug.cgi?id=55198
Comment 1 Peter Robinson 2013-02-19 16:38:34 EST
Created attachment 699677 [details]
output from failed build
Comment 2 Jakub Jelinek 2013-02-20 04:46:08 EST
Guess garbage in, garbage out, I don't see how
 __raw_readw (__typesafe_io (0xfee00000 + ((0x1F1) & ((resource_size_t) 0xfffff))))
could ever work at least on strict alignment machines, 0x1F1 clearly isn't 2-byte aligned.

That said, tracking this upstream, gcc shouldn't ICE even on garbage.

Note You need to log in before you can comment on or make changes to this bug.