Bug 91292 - Split php-manual files by language
Summary: Split php-manual files by language
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-20 21:18 UTC by Matthew Saltzman
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-11 16:58:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Saltzman 2003-05-20 21:18:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The php-manual RPM is extremely large, due to the fact that copies of the manual
for all languages are included in this single RPM.

Please break the copies out by language and create separate RPMs for each.

Version-Release number of selected component (if applicable):
php-manual-4.2.2-17

How reproducible:
Always

Steps to Reproduce:
1. Install php-manual RPM
2. Observe the large amount of disk space taken up by files that you will never
look at because you don't read those languages.
    

Actual Results:  Said amount of disk space is very large.

Expected Results:  Said amount of disk space should be very small.

Additional info:

Comment 1 Bill Rugolsky, Jr. 2003-08-25 21:48:44 UTC
This bug duplicates all or part of 60510, 63217, 70071.  But could we please
have an explanation of why static html documentation belongs in /var?  If no
explanation is forthcoming, please put it in /usr, where it arguably belongs.

Comment 2 Matthew Saltzman 2003-08-26 01:18:26 UTC
OK I see the disposition of the other bugs indicates that the RPM is "langified"
so only installation languages should be installed with the php-manual RPM, but
I just installed it on a machine with only English selected at install and
nevertheless, "du -ks /var/www/manual/mod/mod_php4" reports (among other things):

13198   de
12818   es
12930   fr
13324   it
13780   ja
10750   ko
13533   pt_BR

That doesn't seem all that "langified" to me.  (How does RPM know what the
languages are, anyway?)

And I agree that this all probably belongs in
/usr/share/doc/php-manual-<whatever> anyway.

Comment 3 Joe Orton 2003-09-17 11:27:03 UTC
It's in /var/www/manual because historically that's where the Apache module
manuals have been.  I'm really just tempted to remove the non-English PHP
manuals, they're all available on the web anyway.

Comment 6 Joe Orton 2003-10-23 12:15:24 UTC
This is resolved in 4.3.3-6 for Fedora Core 1 by less subtle means:

- remove manual: up-to-date manual sources are no longer DFSG-free;
  it's too big; it's on the web anyway; #91292, #105804, #107384



Note You need to log in before you can comment on or make changes to this bug.