Bug 912934 - EPEL request
Summary: EPEL request
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kaudiocreator
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dmitrij S. Kryzhevich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-20 03:02 UTC by Ben
Modified: 2013-05-22 21:37 UTC (History)
2 users (show)

Fixed In Version: kaudiocreator-1.3-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-22 21:37:50 UTC


Attachments (Terms of Use)

Description Ben 2013-02-20 03:02:04 UTC
Description of problem: I would like to see kaudiocreator in EPEL-6. Any chance of maintaining it there as well as Fedora? If not, I'm interested in helping out. Thanks.

Comment 1 Dmitrij S. Kryzhevich 2013-02-20 04:53:14 UTC
I had never worked with RHEL/EPEL. So, I need to check differences.

In general: yes, it is possible. It will take some time for me (some differences in spec) but possible.

Comment 2 Orion Poplawski 2013-02-20 22:50:57 UTC
Dmitrij - There are no differences for EPEL6 at the moment:

https://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies#EL6

The package builds fine as is in EPEL6, so there should be much to it other than requesting a branch, building, and pushing an update.

Comment 3 Dmitrij S. Kryzhevich 2013-02-22 07:19:23 UTC
May be I shoud pay more attention to the epel project.

Branch has been requested.

Comment 4 Fedora Update System 2013-02-25 05:58:35 UTC
kaudiocreator-1.3-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/kaudiocreator-1.3-4.el6

Comment 5 Fedora Update System 2013-02-25 18:33:48 UTC
kaudiocreator-1.3-4.el6 has been pushed to the Fedora EPEL 6 testing repository.

Comment 6 Ben 2013-02-26 01:57:06 UTC
Thanks! I'm getting the following error:
Error: Package: kaudiocreator-1.3-4.el6.i686 (epel-testing)
           Requires: audiocd-kio

Comment 7 Fedora Update System 2013-02-26 05:00:14 UTC
kaudiocreator-1.3-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/kaudiocreator-1.3-5.el6

Comment 8 Dmitrij S. Kryzhevich 2013-02-26 05:04:03 UTC
audiocd-kio and kio_audiocd... Redhat has not audiocd-kio package at this moment, it has package with Provides:kio_audiocd. Should be OK now.

Comment 9 Ben 2013-02-27 01:51:14 UTC
This is what I'm getting now:
Error: Package: kaudiocreator-1.3-5.el6.i686 (epel-testing)
           Requires: kio_audiocd
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 10 Dmitrij S. Kryzhevich 2013-02-27 04:32:33 UTC
Hm. This requies much more to digg into.
Looks like there are no Provides:kio_audiocd in rhel version of kdemultimedia.

And looking into binary package and rhel spec, I can't determine is there this kio support at all.

I'l try to make this package works in a couple of days. Looks like I realy have to to make Centos+EPEL virtual machine. Hopped I'm not :)

Comment 11 Fedora Update System 2013-02-27 07:14:23 UTC
kaudiocreator-1.3-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/kaudiocreator-1.3-6.el6

Comment 12 Dmitrij S. Kryzhevich 2013-02-27 07:29:19 UTC
I hope it is the last one.

Comment 13 Ben 2013-03-01 02:32:53 UTC
I installed the latest package, and it seems to work fine - thanks. Do you need me to give any feedback to help move it from testing to the main repo?

Comment 14 Dmitrij S. Kryzhevich 2013-03-01 03:19:18 UTC
Carma threshold value is 3. So - thank you, no need (or you have two more testers?).
In two weeks it will be in stable.

Comment 15 Fedora End Of Life 2013-04-03 20:36:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19

Comment 16 Fedora Update System 2013-05-22 21:37:50 UTC
kaudiocreator-1.3-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.