Bug 912946 - gluster error while generating sosreport in RHEL 6.4.
Summary: gluster error while generating sosreport in RHEL 6.4.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: pre-dev-freeze
: 6.7
Assignee: Shane Bradley
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-20 03:32 UTC by Gowrishankar Rajaiyan
Modified: 2018-12-09 16:56 UTC (History)
15 users (show)

Fixed In Version: sos-3.2-16.el6
Doc Type: Bug Fix
Doc Text:
The "glusterfsd: no process killed" message could previously be displayed in the standard output stream when generating a report. This update modifies the gluster plug-in to use the built-in callout functions, and the message is no longer displayed in this situation.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:32:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1323 normal SHIPPED_LIVE sos bug fix and enhancement update 2015-07-20 17:53:12 UTC
Red Hat Knowledge Base (Solution) 466403 None None None Never
Red Hat Knowledge Base (Solution) 650123 None None None Never

Description Gowrishankar Rajaiyan 2013-02-20 03:32:51 UTC
Description of problem: While executing sosreport on RHEL 6.4 machine "glusterfsd: no process killed" message is displayed.


Version-Release number of selected component (if applicable):
glusterfs-3.3.0.5rhs-42.el6rhs.x86_64
sos-2.2-38.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. execute "sosreport"

  
Actual results:
"glusterfsd: no process killed" displayed.

Expected results:


Additional info:
[root@rhs-gp-srv14 ~]# sosreport 

sosreport (version 2.2)

This utility will collect some detailed  information about the
hardware and setup of your Red Hat Enterprise Linux system.
The information is collected and an archive is  packaged under
/tmp, which you can send to a support representative.
Red Hat Enterprise Linux will use this information for diagnostic purposes ONLY
and it will be considered confidential information.

This process may take a while to complete.
No changes will be made to your system.

Press ENTER to continue, or CTRL-C to quit.

Please enter your first initial and last name [rhs-gp-srv14]: 
Please enter the case number that you are generating this report for [None]: client

glusterfsd: no process killed            <<<<<<<<<<<<<<<<<<<<<<
  Running plugins. Please wait ...

  Completed [53/53] ...      
Creating compressed archive...

Your sosreport has been generated and saved in:
  /tmp/sosreport-rhs-gp-srv14-20130220084245-6cde.tar.xz

The md5sum is: e7f7b382864f38ccee1c5b768f326cde

Please send this file to your support representative.

[root@rhs-gp-srv14 ~]#

Comment 2 Amar Tumballi 2013-02-20 08:44:25 UTC
RaBhat,
can we do 'ps aux| grep glusterfs| grep -v grep' to check the process is running before issuing the signal?

Comment 3 Bryn M. Reeves 2013-02-20 11:48:54 UTC
Better to use pgrep/pkill - we try to avoid launching pipelines from sos (or simply suppress the error from the attempted kill).

Comment 4 Bryn M. Reeves 2014-04-08 12:43:05 UTC
This happens because the gluster plugin decided to roll its own callout mechanism:

        #self.collectExtOutput("killall -USR1 glusterfs glusterfsd")
        os.system("killall -USR1 glusterfs glusterfsd");

Don't do that: use the already provided PluginBase APIs:

  callExtProg()
  collectExtOutput()
  collectOutputNow()

In this instance the first is probably correct since the plugin doesn't care about storing the output in the report.

    self.callExtProg("killall -USR1 glusterfs glusterfsd")

Should do what you want.

Comment 5 Bryn M. Reeves 2014-04-08 12:51:09 UTC
I've fixed this upstream on master:

commit adc1be1ecab468aed5dbac64b7b7d1ce0cc92180
Author: Bryn M. Reeves <bmr@redhat.com>
Date:   Tue Apr 8 13:48:40 2014 +0100

    Replace os.system() in gluster plugin with self.check_ext_prog()
    
    Plugins should not open-code calls to external commands. Use the
    build-in check_ext_prog() interface instead and test for success
    before attempting to collect the statedump files.
    
    Signed-off-by: Bryn M. Reeves <bmr@redhat.com>

The RHEL6 version will be slightly different as we don't currently have checkExtProg(). We can either backport that (trivial) or adapt the gluster change to use callExtProg() and check the returned status.

Comment 6 Christian Horn 2014-08-29 11:44:22 UTC
A partner reports the 
  glusterfs: no process killed
  glusterfsd: no process killed
on a rhel6.6beta.

I am irritated that this bz is for 6.4, yet component was set to RHS.
Should the component be changed, or a different bz be opened?

Comment 12 errata-xmlrpc 2015-07-22 06:32:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1323.html


Note You need to log in before you can comment on or make changes to this bug.