Bug 913002 - Provide a Validation process for ntp parameter sets during automated installation.
Summary: Provide a Validation process for ntp parameter sets during automated installa...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Keywords:
Depends On:
Blocks: rhevh-6.6
TreeView+ depends on / blocked
 
Reported: 2013-02-20 08:02 UTC by haiyang,dong
Modified: 2016-02-10 20:10 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-02-11 20:43:55 UTC


Attachments (Terms of Use)
attached Screenshot for network Page (60.49 KB, image/png)
2013-02-20 08:02 UTC, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description haiyang,dong 2013-02-20 08:02:04 UTC
Created attachment 699869 [details]
attached Screenshot for network Page

Description of problem:
Auto install RHEV-H missed to provide a Validation process for ntp parameter sets.
BOOTIF=eth0 storage_init=/dev/sda ntp=192.168.2.253:192.168.2.254 firstboot
After auto install success, login rhev-h and check the netwrok page(seen network page.png) 

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20130214.0.el6

How reproducible:
100%

Steps to Reproduce:

Actual results:
No Validation process for ntp parameter sets during automated installation.

Expected results:
Provide a Validation process for ntp parameter sets during automated installation.

Additional info:
--

Comment 3 Mike Burns 2013-06-10 23:11:46 UTC
let's validate that the input is valid ip/hostname and *not* set it if it's not valid.  Don't fail the auto-install, but report it in ovirt.log

Comment 4 Fabian Deutsch 2013-12-10 19:38:12 UTC
Haiyang,

didn't you prepare some patches for this? Or do I recall this incorrect?

Comment 5 haiyang,dong 2013-12-11 04:45:51 UTC
(In reply to Fabian Deutsch from comment #4)
> Haiyang,
> 
> didn't you prepare some patches for this? Or do I recall this incorrect?

rbarry prepared a patch for this bug:
http://gerrit.ovirt.org/#/c/17888/

Comment 7 Fabian Deutsch 2014-07-24 16:03:12 UTC
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.

Comment 8 haiyang,dong 2014-11-12 06:04:34 UTC
Test version:
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch

Test Steps
1. BOOTIF=eth0 storage_init=/dev/sda ntp=10.66.11.225:10.66.72.80 firstboot
2. After auto install success, login rhev-h and check the netwrok page

Now NTP Server 1 didn't accept "10.66.11.225:10.66.72.80" as it's value, so rhevh has provided a Validation process for ntp parameter sets during automated installation.

so this bug has been fixed in in rhevh 6.6 for RHEV 3.5 bulid version, change the status into "VERIFIED"

Comment 10 errata-xmlrpc 2015-02-11 20:43:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.