This is an automatically created tracking bug! It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of Fedora EPEL.
For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.
For more information see:
When creating a Bodhi update request, please use the bodhi submission link
noted in the next comment(s). This will include the bug IDs of this
tracking bug as well as the relevant top-level CVE bugs.
Please also mention the CVE IDs being fixed in the RPM changelog and the
Bodhi notes field when available.
epel-5 tracking bug for Django: see blocks bug list for full details of the security issue(s).
[bug automatically created by: add-tracking-bugs]
Please use the following update submission link to create the Bodhi
request for this issue as it contains the top-level parent bug(s) as well
as this tracking bug. This will ensure that all associated bugs get
updated when new packages are pushed to stable.
Please also ensure that the "Close bugs when update is stable" option
Bodhi update submission link:
Adding parent bug 913039. Please use this new bodhi update url when correcting
Adding parent bug CVE-2013-0305. Please use this new bodhi update url when correcting
Adding parent bug CVE-2013-0306. Please use this new bodhi update url when correcting
Django on EPEL5 is Django-1.1, it doesn't receive any updates any more since Django-1.3 was released, and that has been a loooong time.
Can you make sure it's properly obsoleted and removed form EPEL if it's no longer updated with security fixes?
Never Django versions require never python versions, e.g. Django 1.5 (current version) requires python2.7 or python 3.
Of course I can deprecate and retire from EPEL5, but what does this help?
We don't want to ship packages that contain security vulnerabilities, I suppose, especially when alternatives exist (people who really want to use Django on EL5 could install Django 1.4.x on top of python26-virtualenv - though when Django 1.4.x also goes out of support they'd be in a pickle)
As explained by Michel, keeping known vulnerable and known unsupported package around is not ideal. Its removal can also prevent similar future bugs.
I absolutely agree, I've sent a mail about retiring Django-1.1 to epel-devel list: