Bug 913165 - Repeat: input inside repeat in not updated
Summary: Repeat: input inside repeat in not updated
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise WFK Platform 2
Classification: Retired
Component: RichFaces
Version: 2.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 2.3.0
Assignee: Brian Leathem
QA Contact: Pavol Pitonak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-20 14:41 UTC by Pavol Pitonak
Modified: 2013-07-16 11:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The HTML input element rendered by the h:inputText JSF component did not contain the "value" attribute. Consequently, when entering text into the input field, submitting it, and trying to clear the input text by clearing the bound value on the server side, the received partial update did not clear the input field in the browser. The issue originated in Mojarra 2.1.13, which is included in JBoss Enterprise Application Platform 6.0.1. No workaround for the issue is known, but it can be solved by upgrading to JBoss Enterprise Application Platform 6.1.0, which contains a different version of Mojarra that is not affected by the issue.
Clone Of:
Environment:
RichFaces 4.3.0.Final-redhat-1 Metamer 4.3.0.Final-redhat-1 Mojarra 2.1.13-redhat-1 EAP 6.0.1 Java(TM) SE Runtime Environment 1.7.0_04-b20 @ Linux Chrome 24.0.1312.70 @ Linux x86_64
Last Closed: 2013-07-16 11:32:50 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker RF-12512 Major Resolved Repeat: input inside repeat in not updated 2014-04-25 07:37:26 UTC

Description Pavol Pitonak 2013-02-20 14:41:10 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. deploy Metamer and open http://localhost:8080/metamer/faces/components/a4jRepeat/matrix.xhtml
2. click the top-left "+" link
3. click the top-left "C" link
  
Actual results:
output below is reset but input's value not

Expected results:
both input and output value are reset

Additional info:
Worked fine in EAP 6.0.0 (Mojarra 2.1.7) but doesn't work in EAP 6.0.1 (Mojarra 2.1.13). Upstream issue RF-12512 indicates that it works fine with Mojarra 2.1.16.

Comment 1 Marek Novotny 2013-02-26 18:28:19 UTC
Pavol, please update this bz, I can see that linked RF-12512 was closed as OUT OF DATE

Comment 2 Pavol Pitonak 2013-02-27 11:34:50 UTC
Marek it was marked as out of date because it works with Mojarra 2.1.16 used for cummunity testing. However, EAP 6.0.1 contain Mojarra 2.1.13 with which it's broken.

Comment 3 Marek Novotny 2013-02-27 13:01:51 UTC
If you located as 2.1.13 is only problematic, when this is just a documentation issue or will RF team workaround it?

Comment 4 JBoss JIRA Server 2013-02-28 00:15:41 UTC
Brian Leathem <bleathem@gmail.com> updated the status of jira RF-12512 to Reopened

Comment 5 JBoss JIRA Server 2013-02-28 00:15:41 UTC
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-12512

Re-opening to target EAP 6.0.1

Comment 7 JBoss JIRA Server 2013-03-08 18:43:57 UTC
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-12512

I wrote a _fundamental_ test to reproduce this behaviour.  I can confirm:

# it worked in Mojarra 2.1.7 (shipped with AS 7.1.1.Final)
# it starts failing in Mojarra 2.1.8
# starts working again in Mojarra 2.1.15

I'll next use the _fundamental_ test to investigate if there is something we can do to workaround this issue.

Comment 8 JBoss JIRA Server 2013-03-08 20:04:56 UTC
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-12512

This in fact has nothing to do with _<a4j:repeat>_ nor any RichFaces component for that matter.  I was able to reproduce the behaviour with the following "plain old" JSF:

{code}
<h:form id='myForm'> ");
    <h:inputText id='input' value='#{ajaxBean.value}'/> ");
    <h:commandButton id='submit' value = 'Submit Input'> ");
        <f:ajax execute='input' render='input' /> ");
    </h:commandButton> ");
    <h:commandButton id='clear' value = 'Clear Input'> ");
        <f:ajax listener='#{ajaxBean.clearValue}' render='input' /> ");
    </h:commandButton> ");
</h:form>
{code}

Comment 9 JBoss JIRA Server 2013-03-08 20:05:16 UTC
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-12512

This in fact has nothing to do with _<a4j:repeat>_ nor any RichFaces component for that matter.  I was able to reproduce the behaviour with the following "plain old" JSF:

{code}
<h:form id='myForm'>
    <h:inputText id='input' value='#{ajaxBean.value}'/>
    <h:commandButton id='submit' value = 'Submit Input'>
        <f:ajax execute='input' render='input' />
    </h:commandButton>
    <h:commandButton id='clear' value = 'Clear Input'>
        <f:ajax listener='#{ajaxBean.clearValue}' render='input' />
    </h:commandButton>
</h:form>
{code}

Comment 10 JBoss JIRA Server 2013-03-08 20:05:48 UTC
Brian Leathem <bleathem@gmail.com> updated the status of jira RF-12512 to Resolved

Comment 11 JBoss JIRA Server 2013-03-08 20:05:48 UTC
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-12512

This turns out then to be entirely an upstream issue: JAVASERVERFACES-2578.  Resolving would require a patch to the Mojarra 2.1.13 impl bundled with EAP.

Comment 12 Petr Penicka 2013-03-28 18:19:35 UTC
Doc text added. Pavol or Brian, please verify it is correct.

Comment 13 Brian Leathem 2013-03-28 18:25:11 UTC
Added an HTML clarifier before the input tag.  Otherwise it looks good to me.

Comment 14 Petr Penicka 2013-04-02 18:53:02 UTC
Included in the release notes book:

Comment 16 Marek Schmidt 2013-07-01 16:26:52 UTC
@ppitonak, does this issue occurs also on EAP 6.1? If so, please update the RN.

Comment 17 Pavol Pitonak 2013-07-02 13:07:05 UTC
Marek, it works correctly in EAP 6.1 which contains Mojarra 2.1.19.

Comment 18 Petr Penicka 2013-07-04 11:19:53 UTC
Edited doc text for wfk 2.3 release notes.


Note You need to log in before you can comment on or make changes to this bug.