Bug 913191 - Old selinux man page and missing some additional info about switching the policy
Old selinux man page and missing some additional info about switching the policy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.4
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Peter Schiffer
Iveta Wiedermann
: ManPageChange, Patch
Depends On: 913184
Blocks: 1011145
  Show dependency treegraph
 
Reported: 2013-02-20 10:54 EST by Michal Trunecka
Modified: 2014-09-30 19:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: outdated selinux(8) man page Consequence: outdated documentation Fix: update selinux(8) man page Result: current documentation
Story Points: ---
Clone Of: 913184
Environment:
Last Closed: 2013-11-21 17:56:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
selinux.8.patch (5.20 KB, patch)
2013-09-19 09:55 EDT, Peter Schiffer
no flags Details | Diff
selinux.8.patch (5.20 KB, patch)
2013-10-24 08:53 EDT, Peter Schiffer
no flags Details | Diff

  None (edit)
Description Michal Trunecka 2013-02-20 10:54:02 EST
+++ This bug was initially created as a clone of Bug #913184 +++

Description of problem:

There are a few pieces of information in the selinux man page (man selinux) that aren't true any more:

"At present, two kinds of SELinux policy exist: targeted and strict."

"It is anticipated in the future that other policies will be created (Multi-Level Security for  example)."


and I also miss some additional information about switching the policy there. There is only stated that I can switch policy by changing the SELINUXTYPE value in /etc/selinux/config, but there is no information about when this change actually happen. I belive it is necessary to reboot the machine, but that is not mentioned there. Since a lot of tools takes the policy type from the config file, the system is in somewhat inconsistent state right after editing the configuration.


Version-Release number of selected component (if applicable):

# rpm -qf /usr/share/man/man8/selinux.8.gz
libselinux-utils-2.1.13-3.el7.x86_64
Comment 2 Peter Schiffer 2013-09-19 09:55:22 EDT
Created attachment 799958 [details]
selinux.8.patch
Comment 8 Peter Schiffer 2013-10-24 08:53:10 EDT
Created attachment 815764 [details]
selinux.8.patch
Comment 12 errata-xmlrpc 2013-11-21 17:56:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1695.html

Note You need to log in before you can comment on or make changes to this bug.