Bug 913215 - ns-slapd segfaults while trying to delete a tombstone entry
Summary: ns-slapd segfaults while trying to delete a tombstone entry
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.5
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Rich Megginson
QA Contact: Sankar Ramalingam
URL:
Whiteboard:
Depends On:
Blocks: 914305
TreeView+ depends on / blocked
 
Reported: 2013-02-20 16:30 UTC by Najmuddin Chirammal
Modified: 2018-12-02 17:54 UTC (History)
7 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-14.el6_4
Doc Type: Bug Fix
Doc Text:
While trying to remove a tombstone entry, the ns-slapd daemon terminated unexpectedly with a segmentation fault. With this update, removal of tombstone entries no longer causes crashes.
Clone Of:
Environment:
Last Closed: 2013-11-21 21:04:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1653 normal SHIPPED_LIVE 389-ds-base bug fix update 2013-11-20 21:53:19 UTC

Description Najmuddin Chirammal 2013-02-20 16:30:31 UTC
Description of problem: While trying to remove a tombstone entry, ns-slapd crashed with segfault. 

Version-Release number of selected component : 389-ds-base-1.2.11.15-11

How reproducible: Always.

Steps to Reproduce: 
1. search for nstombstone entry
# ldapsearch -x -D cn=directory\ manager -W -b <base> objectClass=nstombstone

2. try to delete the entry.
# ldapdelete -x -D cn=directory\ manager, -W nsuniqueid=80247281-58ea11e2-8b149459-690938d9,uid=abc,cn=users,cn=accounts,dc=gsslab,dc=pnq,dc=redhat,dc=com
3. check the output (fails with ldap server un-available error)
  
Actual results: The delete request causes ns-slapd to segfault, the command fails with ldap server un-available.

Expected results: The entry get removed from the DS and no segfault.

Additional info: 

- I do not see the issue in older releases. (tried  389-ds-base-1.2.11.15-3.el6 and 389-ds-base-1.2.10.2-20.el6_3 ).

- ds is a part of ipa and replication is configured.

- stack trace: 

Core was generated by `/usr/sbin/ns-slapd -D /etc/dirsrv/slapd-GSSLAB-PNQ-REDHAT-COM -i /var/run/dirsr'.
Program terminated with signal 11, Segmentation fault.
#0  csn_get_replicaid (csn=0x0) at ldap/servers/slapd/csn.c:192
192	{
#0  csn_get_replicaid (csn=0x0) at ldap/servers/slapd/csn.c:192
#1  0x00007fa016afcde3 in write_changelog_and_ruv (pb=0x2a31460) at ldap/servers/plugins/replication/repl5_plugins.c:1067
#2  0x00000031bcc8fd8a in plugin_call_func (list=0x2625b70, operation=563, pb=0x2a31460, call_one=0) at ldap/servers/slapd/plugin.c:1453
#3  0x00000031bcc8ffbf in plugin_call_list (pb=0x2a31460, whichfunction=563) at ldap/servers/slapd/plugin.c:1415
#4  plugin_call_plugins (pb=0x2a31460, whichfunction=563) at ldap/servers/slapd/plugin.c:398
#5  0x00007fa016da0126 in ldbm_back_delete (pb=0x2a31460) at ldap/servers/slapd/back-ldbm/ldbm_delete.c:1007
#6  0x00000031bcc4c153 in op_shared_delete (pb=0x2a31460) at ldap/servers/slapd/delete.c:364
#7  0x00000031bcc4c491 in do_delete (pb=0x2a31460) at ldap/servers/slapd/delete.c:128
#8  0x00000000004140f4 in connection_dispatch_operation () at ldap/servers/slapd/connection.c:583
#9  connection_threadmain () at ldap/servers/slapd/connection.c:2338
#10 0x0000003a9ea299e3 in ?? () from /lib64/libnspr4.so
#11 0x0000003b0c607851 in start_thread (arg=0x7f9fed1f4700) at pthread_create.c:301
#12 0x0000003b0bee811d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Comment 2 Nathan Kinder 2013-02-20 17:39:33 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/590

Comment 6 Ján Rusnačko 2013-08-23 07:30:13 UTC
Verified on 389-ds-base-1.2.11.15-22.el6.x86_64

Comment 7 errata-xmlrpc 2013-11-21 21:04:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1653.html


Note You need to log in before you can comment on or make changes to this bug.