Bug 913411 - SOAPFaultException cannot render SOAP 1.2 Fault Subcode in CXF
Summary: SOAPFaultException cannot render SOAP 1.2 Fault Subcode in CXF
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ER4
: EAP 6.1.1
Assignee: Alessio Soldano
QA Contact:
URL: https://issues.jboss.org/browse/WFLY-...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-21 08:27 UTC by Tadayoshi Sato
Modified: 2019-02-15 13:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-16 20:21:54 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Apache JIRA CXF-4790 0 None None None Never
Red Hat Issue Tracker JBWS-3601 0 Major Closed SOAPFaultException cannot render SOAP 1.2 Fault Subcode in CXF 2017-07-13 01:57:01 UTC

Internal Links: 961560

Description Tadayoshi Sato 2013-02-21 08:27:00 UTC
Description of problem:
Platform BZ for https://issues.jboss.org/browse/JBWS-3601

Backport https://issues.apache.org/jira/browse/CXF-4790, which is the root cause. The code below doesn't render <soapenv:Subcode>:

  import javax.xml.soap.SOAPConstants;
  import javax.xml.soap.SOAPFactory;
  import javax.xml.soap.SOAPFault;
  import javax.xml.ws.soap.SOAPFaultException;
  ...
    SOAPFactory factory = SOAPFactory.newInstance(SOAPConstants.SOAP_1_2_PROTOCOL);
    SOAPFault fault = factory.createFault("Operator not found", new QName(SOAPConstants.URI_NS_SOAP_1_2_ENVELOPE, "Receiver"));
    fault.appendFaultSubcode(new QName("...", "OperatorNotFound"));
    ...
    throw new SOAPFaultException(fault);

Comment 1 Rostislav Svoboda 2013-02-22 12:04:32 UTC
Fix Versions for CXF-4790 are 2.8.0, 2.7.4, 2.6.7, 2.5.10

EAP 6.1.0 DR4 is using 2.6.6, version 2.6.7 was not yet released

If this should be included in EAP 6.1.0, jboss-eap-6.1.0 flag must be selected to enter 3-ACK process.

Comment 9 JBoss JIRA Server 2013-03-28 10:18:09 UTC
Alessio Soldano <asoldano@redhat.com> made a comment on jira JBWS-3601

From a community point of view, the fix for this is coming in next CXF version. Scheduling for jbossws-cxf-4.2

Comment 11 JBoss JIRA Server 2013-04-05 16:35:14 UTC
Alessio Soldano <asoldano@redhat.com> updated the status of jira JBWS-3601 to Resolved

Comment 12 JBoss JIRA Server 2013-04-05 16:35:14 UTC
Alessio Soldano <asoldano@redhat.com> made a comment on jira JBWS-3601

Solving this upstream jira as a consequence of having moved to cxf 2.7.4

Comment 13 mark yarborough 2013-06-04 21:31:23 UTC
Was proposed or approved for 6.1.0 but did not make it into the payload, so setting jboss-eap-6.1.0- (for history) and jboss-eap-6.1.1? (to try again)

Comment 14 Carlo de Wolf 2013-07-08 09:55:54 UTC
ER3 contains 2.6.8 which has supposedly fixed the issue.

Comment 15 Emmanuel Hugonnet (ehsavoie) 2013-07-10 10:24:11 UTC
Looks like this is not enough with EJB exposed as webservices.

Comment 16 Emmanuel Hugonnet (ehsavoie) 2013-07-11 07:26:53 UTC
PR: https://github.com/jbossas/jboss-eap/pull/236

Comment 18 Petr Sakař 2013-08-07 12:43:02 UTC
Verified by running test against EAP-6.1.1.ER3 (failed) and EAP-6.1.1.ER4 (passed)

References
Upstream test in 4.2 https://source.jboss.org/changelog/JBossWS?cs=17768
EAP6.1 test https://github.com/jbossas/jboss-eap/pull/236

Procedure
git clone git clone https://github.com/jbossas/jboss-eap.git
cd jboss-eap
git tags -l
git checkout tags/EAP_6.1.1.ER4
start-as #EAP_6.1.1.ER4
mvn -s tools/maven/conf/settings.xml test -Dts.basic -Dtest=org.jboss.as.test.integration.ws.basic.*TestCase -pl :jboss-as-ts-integ-basic
#tests passed#
stop-as
start-as #EAP_6.1.1.ER3 previous version
mvn -s tools/maven/conf/settings.xml test -Dts.basic -Dtest=org.jboss.as.test.integration.ws.basic.*TestCase -pl :jboss-as-ts-integ-basic
#test failed#

Comment 20 Scott Mumford 2013-08-29 03:57:55 UTC
Marking for exclusion from the 6.1.1 Release Notes document as an entry for this bug could not be completed or verified in time.

Comment 22 JBoss JIRA Server 2013-10-21 14:05:30 UTC
Alessio Soldano <asoldano@redhat.com> updated the status of jira JBWS-3601 to Closed


Note You need to log in before you can comment on or make changes to this bug.