Bug 91344 - SMP machine doesn't power off when told to.
Summary: SMP machine doesn't power off when told to.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-21 17:21 UTC by Fredrik Rambris
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-08 13:16:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fredrik Rambris 2003-05-21 17:21:05 UTC
Description of problem:
When selecting power off in either desktop or gdm the machine goes all the way
to the disk flush and sais powering down but it doesn't.

Version-Release number of selected component (if applicable):
All kernels shipped with RHL 9.

How reproducible:
I can't say for sure but I have an ABIT BP6 mobo with two PIII CPUs.


Steps to Reproduce:
1. Install ABIT BP6 mobo
2. Install RHL9 or RHL8
3. Try to power off with SMP kernel.
    
Actual results:


Expected results:


Additional info:
The cure for this is simple on my machine. I add an apm=power-off to the kernel
parameters and it works.

I have the same problem on my Fujitsu-Siemens Lifebook E7010 (i815 chipset, P4)
but the apm=power-off doesn't help there.

Comment 1 Arjan van de Ven 2003-05-22 09:29:08 UTC
"The cure for this is simple on my machine. I add an apm=power-off to the kernel
parameters and it works."

Since this crashes on a huge part of the machines out there we can't make this
the default unfortionatly.

On your laptop, does dmesg show that APM is enabled AT ALL ?

Comment 2 Fredrik Rambris 2003-05-22 21:45:22 UTC
dmesg | grep -i apm sais
apm: BIOS version 1.2 Flags 0x1b (Driver version 1.16)

Comment 3 Fredrik Rambris 2003-05-22 22:09:48 UTC
Just to clarify. The laptop bug should be separate from the SMP bug as the
laptop isn't a SMP machine.

I managed to get the laptop to power down. I found no power management in bios
on machine and figured that it must be ACPI only. I recompiled the kernel with
no APM and all ACPI and the machine powers down as expected.

Comment 4 Alan Cox 2003-06-08 13:16:47 UTC
The SMP one we can't fix. The laptop will resolve when ACPI is in a state we are
happy to ship it



Note You need to log in before you can comment on or make changes to this bug.