Bug 91345 - neat doesn't set wireless key when activating a wireless networking device
Summary: neat doesn't set wireless key when activating a wireless networking device
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-21 17:28 UTC by David Burley
Modified: 2014-03-17 02:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-29 20:09:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Burley 2003-05-21 17:28:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The networking administration tool 'neat' does not configure the wireless key;
despite having a field to enter it into. Thus, I cannot activate the card
without running 'iwconfig eth1 key KEYDATA' before activating the device in
'neat'. It would also be nice if the device could really work upon boot rather
than having to enter neat to enable it. Sure, I could write up some shell
scripts to fix this... but then why do we have a tool for it?

Version-Release number of selected component (if applicable):
1.2.0

How reproducible:
Always

Steps to Reproduce:
1. Run 'neat'
2. Activate the wireless card with a WEP key (this step will fail)
3. type '/sbin/iwconfig' and note that the wireless key is not enabled
    

Actual Results:  The wireless card was not connected to the network.

Expected Results:  The wireless card should have been connected to the network.

Additional info:

The WEP key is a 104bit WEP key
The wireless card is a Lucent Technologies 'Orinoco Gold' model

Comment 1 Harald Hoyer 2003-05-22 09:29:23 UTC
please try the update from:
http://people.redhat.com/harald/redhat-config-network

Comment 2 David Burley 2003-05-22 22:50:49 UTC
Greetings,

I have installed the updates provided and we are a step closer, but still not
completely where we should be. The card still does not get the wireless key set
before trying to configure the network settings, thus no network connection is
ever made. 

As a workaround, I have simply made the rc.local file run iwconfig for me to set
the WEP key and all works fine. So, this new version still doesn't seem to get
that step right.

Thanks,

David

Comment 3 Harald Hoyer 2004-07-29 15:58:30 UTC
hmm, this is the job of the network initscripts. They define the ordering.

Comment 4 Bill Nottingham 2004-07-29 18:21:47 UTC
Please attach your config file.

Comment 5 David Burley 2004-07-29 19:41:47 UTC
Thanks for the help.... but I reported this issue on 2003-05-21 it is
now 2004-07-29 and I have moved along to Fedora Core 2, since. And as
RH9 is deprecated at this point, I am not sure why any resources are
being allocated to this issue.

Comment 6 Bill Nottingham 2004-07-29 19:43:11 UTC
Does it work in FC2?

Comment 7 David Burley 2004-07-29 19:57:15 UTC
I selected desktop install instead of laptop... so a lot of things
needed to be customized afterwards... I assume that is because I
selected the 'wrong' install option. As such, I am not sure if this is
still outstanding or not in FC2.

Comment 8 Bill Nottingham 2004-07-29 20:09:11 UTC
OK, please reopen if it persists at a later point.


Note You need to log in before you can comment on or make changes to this bug.