Bug 913543 - [abrt] dnf-0.2.21-1.git050524e.fc18: __init__.py:2760:history_undo:TypeError: remove() got an unexpected keyword argument 'pkgtup'
[abrt] dnf-0.2.21-1.git050524e.fc18: __init__.py:2760:history_undo:TypeError:...
Status: CLOSED DUPLICATE of bug 878348
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:028adca37b809bbc5eeaaf13da2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-21 07:49 EST by Michal Schmidt
Modified: 2013-02-21 11:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 11:13:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.27 KB, text/plain)
2013-02-21 07:49 EST, Michal Schmidt
no flags Details
File: core_backtrace (725 bytes, text/plain)
2013-02-21 07:49 EST, Michal Schmidt
no flags Details
File: environ (1.65 KB, text/plain)
2013-02-21 07:50 EST, Michal Schmidt
no flags Details
File: smolt_data (2.65 KB, text/plain)
2013-02-21 07:50 EST, Michal Schmidt
no flags Details

  None (edit)
Description Michal Schmidt 2013-02-21 07:49:52 EST
Description of problem:
1. dnf install squid
2. dnf history undo last

Version-Release number of selected component:
dnf-0.2.21-1.git050524e.fc18

Additional info:
cmdline:        /usr/bin/python /bin/dnf history undo last
executable:     /bin/dnf
kernel:         3.7.8-202.fc18.x86_64
uid:            0

Truncated backtrace:
__init__.py:2760:history_undo:TypeError: remove() got an unexpected keyword argument 'pkgtup'

Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 305, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in main
    result, resultmsgs = cli.do_commands()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1468, in do_commands
    return command.doCommand(self.base.basecmd, self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 2271, in doCommand
    ret = self._hcmd_undo(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 2137, in _hcmd_undo
    if self.base.history_undo(old):
  File "/usr/lib/python2.7/site-packages/dnf/yum/__init__.py", line 2760, in history_undo
    if self.remove(pkgtup=pkg.pkgtup):
TypeError: remove() got an unexpected keyword argument 'pkgtup'

Local variables in innermost frame:
self: <dnf.cli.cli.YumBaseCli object at 0x1159e50>
transaction: <dnf.yum.history.YumHistoryTransaction instance at 0x1194e18>
done: False
pkg: <YumHistoryPackageState : libecap-0.2.0-4.fc18.x86_64 (0x1193390)>
old_conf_obs: True
Comment 1 Michal Schmidt 2013-02-21 07:49:56 EST
Created attachment 700491 [details]
File: backtrace
Comment 2 Michal Schmidt 2013-02-21 07:49:58 EST
Created attachment 700492 [details]
File: core_backtrace
Comment 3 Michal Schmidt 2013-02-21 07:50:00 EST
Created attachment 700493 [details]
File: environ
Comment 4 Michal Schmidt 2013-02-21 07:50:03 EST
Created attachment 700494 [details]
File: smolt_data
Comment 5 Ales Kozumplik 2013-02-21 11:13:31 EST
Hi Michael, I know about this, it is the bug 878348.

*** This bug has been marked as a duplicate of bug 878348 ***

Note You need to log in before you can comment on or make changes to this bug.