Bug 913601 - Send keys menu offset in fullscreen (multi head)
Summary: Send keys menu offset in fullscreen (multi head)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 946999
TreeView+ depends on / blocked
 
Reported: 2013-02-21 15:16 UTC by Tomas Jamrisko
Modified: 2013-11-21 08:08 UTC (History)
13 users (show)

Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: In a multi-monitor guest setup, open the sendkey menu. Consequence: The menu is wrongly placed on the secondary monitors. Fix: Correctly translate the menu coordinates based on the toplevel windows position, Result: The sendkey menu is correctly placed on secondary monitors.
Clone Of:
: 946999 (view as bug list)
Environment:
Last Closed: 2013-11-21 08:08:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description Tomas Jamrisko 2013-02-21 15:16:59 UTC
Description of problem:
Sendkeys menu is offset on the secondary monitor in a setup where both the guest and client have two displays

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-18.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. get a client with 2 monitors
2. connect to a VM (preferably rhel6.4) and open a second display
3. switch to full-screen mode
4. Click Send keys in the hidden menu on upper edge of screen of secondary monitor
  
Actual results:
The menu is open in a wrong position (usually on first monitor or close to an edge)

Expected results:
it should be centered

Comment 2 RHEL Product and Program Management 2013-02-25 06:48:01 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Marc-Andre Lureau 2013-05-14 00:32:26 UTC
sent patch to ML " window: fix send key menu popup position" (not yet in archives..)

Comment 5 Hans de Goede 2013-05-14 06:41:15 UTC
(In reply to comment #4)
> sent patch to ML " window: fix send key menu popup position" (not yet in
> archives..)

Hmm, I did not receive this on the list either, maybe something went wrong? Can you resend ?

Comment 7 Hans de Goede 2013-05-14 13:08:46 UTC
(In reply to comment #6)
> https://www.redhat.com/archives/virt-tools-list/2013-May/msg00038.html

Somehow missed the mail, looks good, ACK.

Comment 13 CongDong 2013-07-05 08:04:31 UTC
I can reproduce this bug:
Version:
virt-viewer-0.5.2-18.el6.x86_64

steps:
1. get a client with 2 monitors
2. connect to a VM (preferably rhel6.4) and open a second display
3. switch to full-screen mode
4. Click Send keys in the hidden menu on upper edge of screen of secondary monitor
5. Try on the other window

result:
Step4, Step5, one of the menu is in the wrong position.

Verify:
virt-viewer-0.5.6-1.el6

Steps:
As the steps above.

result:
The menu in every window is in right position.

Comment 14 errata-xmlrpc 2013-11-21 08:08:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.