Bug 91364 - Compiler error: Missing termios library header
Compiler error: Missing termios library header
Status: CLOSED NOTABUG
Product: eCos
Classification: Retired
Component: Serial device driver (Show other bugs)
2.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Gary Thomas
Jonathan Larmour
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-21 17:34 EDT by Luis Benvenutto
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-21 18:36:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Benvenutto 2003-05-21 17:34:06 EDT
Description of problem:

Compilation fails when the user aplication uses <termios.h>

Version-Release number of selected component (if applicable):

ecoscentric-gnutools-i386-elf-1.4-2

How reproducible:

Steps to Reproduce:
1. Build a generic library for i386
2. Put a line in your source like '#include <termios.h>
3. make INSTALL_DIR=<dir>
    
Actual results:
Relevant output from compiler is:
/opt/ecos/gnutools/i386-elf/i386-elf/include/termios.h:4:25: sys/termios.h: No
such file or directory

Expected results:
Succesful compilation

Additional info:
Comment 1 Jonathan Larmour 2003-05-21 18:36:59 EDT
It looks like you haven't added the eCos header directory into the include path
of the compiler. Have a read of the Tutorial document, but in summary you're
meant to do something similar to -I/myecosinstalldir/include

Then it will pick up the eCos termios.h in preference.

Note You need to log in before you can comment on or make changes to this bug.