Bug 91383 - finger @finger.kernel.org returns nothing
finger @finger.kernel.org returns nothing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: finger (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-21 23:33 EDT by Pete Zaitcev
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-01 22:34:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2003-05-21 23:33:28 EDT
Description of problem:

finger @finger.kernel.org  does not return anything.

Version-Release number of selected component (if applicable):

finger-0.17-16

How reproducible:

Not every time, according to the phase of the moon. But it happens
pretty often.

Actual results:

[zaitcev@niphredil linux-2.4.21-rc2]$ finger @finger.kernel.org
[zaitcev@niphredil linux-2.4.21-rc2]$ 

Expected results:

[zaitcev@devel6 zaitcev]$ finger @finger.kernel.org
The latest stable version of the Linux kernel is:           2.4.20
The latest prepatch for the stable Linux kernel tree is:    2.4.21-rc2
The latest beta version of the Linux kernel is:             2.5.69
The latest snapshot for the beta Linux kernel tree is:      2.5.69-bk15
The latest 2.2 version of the Linux kernel is:              2.2.25
The latest 2.0 version of the Linux kernel is:              2.0.39
The latest prepatch for the 2.0 Linux kernel tree is:       2.0.40-rc6
The latest -ac patch to the stable Linux kernels is:        2.4.21-rc2-ac2
The latest -ac patch to the beta Linux kernels is:          2.5.69-ac1
The latest -dj patch to the beta Linux kernels is:          2.5.69-dj1
[zaitcev@devel6 zaitcev]$

Additional info:

socket(PF_INET, SOCK_STREAM, IPPROTO_TCP) = 4
connect(4, {sa_family=AF_INET, sin_port=htons(79),
sin_addr=inet_addr("204.152.189.116")}, 16) = 0
write(4, "", 0)                         = 0
write(4, "\r\n", 2)                     = 2
fcntl64(4, F_GETFL)                     = 0x2 (flags O_RDWR)
fstat64(4, {st_mode=S_IFSOCK|0777, st_size=0, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x4001c000
_llseek(4, 0, 0xbffff720, SEEK_CUR)     = -1 ESPIPE (Illegal seek)
read(4, "", 4096)                       = 0
close(4)                                = 0
Comment 1 Pete Zaitcev 2003-06-01 01:41:09 EDT
tcpdump: listening on eth0
22:37:52.160808 192.168.128.9.32769 > 192.168.128.1.domain:  59826+ AAAA?
finger.kernel.org. (35) (DF)
22:37:52.163880 192.168.128.1.domain > 192.168.128.9.32769:  59826 1/1/0
CNAME[|domain] (DF)
22:37:52.164093 192.168.128.9.32769 > 192.168.128.1.domain:  59827+ A?
finger.kernel.org. (35) (DF)
22:37:52.170831 192.168.128.1.domain > 192.168.128.9.32769:  59827 2/5/4
CNAME[|domain] (DF)
22:37:52.170955 192.168.128.9.33043 > 204.152.189.116.finger: S
307822075:307822075(0) win 5840 <mss 1460,sackOK,timestamp 4436522 0,nop,wscale
0> (DF)
22:37:52.200179 204.152.189.116.finger > 192.168.128.9.33043: S
422985008:422985008(0) ack 307822076 win 5792 <mss 1412,sackOK,timestamp
392300362 4436522,nop,wscale 0> (DF)
22:37:52.200304 192.168.128.9.33043 > 204.152.189.116.finger: . ack 1 win 5840
<nop,nop,timestamp 4436525 392300362> (DF)
22:37:52.226403 204.152.189.116.finger > 192.168.128.9.33043: F 1:1(0) ack 1 win
5792 <nop,nop,timestamp 392300365 4436525> (DF)
22:37:52.236311 192.168.128.9.33043 > 204.152.189.116.finger: . ack 2 win 5840
<nop,nop,timestamp 4436529 392300365> (DF)
22:37:52.245177 192.168.128.9.33043 > 204.152.189.116.finger: P 1:3(2) ack 2 win
5840 <nop,nop,timestamp 4436529 392300365> (DF)
22:37:52.245280 192.168.128.9.33043 > 204.152.189.116.finger: F 3:3(0) ack 2 win
5840 <nop,nop,timestamp 4436529 392300365> (DF)
22:37:52.267752 204.152.189.116.finger > 192.168.128.9.33043: R
422985010:422985010(0) win 0 (DF)
22:37:52.273710 204.152.189.116.finger > 192.168.128.9.33043: R
422985010:422985010(0) win 0 (DF)
 
13 packets received by filter
0 packets dropped by kernel
Comment 2 Pete Zaitcev 2003-06-01 01:46:32 EDT
Linux version 2.4.20-9 (bhcompile@stripples.devel.redhat.com) (gcc version 3.2.2
20030313 (Red Hat Linux 3.2.2-10)) #1 Wed Apr 2 13:42:50 EST 2003
Comment 3 Pete Zaitcev 2003-06-01 01:50:12 EDT
OK dump, for comparison:

tcpdump: listening on eth0
22:49:24.996563 192.168.128.9.32769 > 192.168.128.1.domain:  43975+ AAAA?
finger.kernel.org. (35) (DF)
22:49:25.000738 192.168.128.1.domain > 192.168.128.9.32769:  43975 1/1/0
CNAME[|domain] (DF)
22:49:25.066974 192.168.128.9.32769 > 192.168.128.1.domain:  43976+ A?
finger.kernel.org. (35) (DF)
22:49:25.073761 192.168.128.1.domain > 192.168.128.9.32769:  43976 2/5/5
CNAME[|domain] (DF)
22:49:25.086579 192.168.128.9.33060 > 204.152.189.116.finger: S
1049177387:1049177387(0) win 5840 <mss 1460,sackOK,timestamp 4505814
0,nop,wscale 0> (DF)
22:49:25.114247 204.152.189.116.finger > 192.168.128.9.33060: S
1151208706:1151208706(0) ack 1049177388 win 5792 <mss 1412,sackOK,timestamp
392369655 4505814,nop,wscale 0> (DF)
22:49:25.114342 192.168.128.9.33060 > 204.152.189.116.finger: . ack 1 win 5840
<nop,nop,timestamp 4505816 392369655> (DF)
22:49:25.162325 192.168.128.9.33060 > 204.152.189.116.finger: P 1:3(2) ack 1 win
5840 <nop,nop,timestamp 4505821 392369655> (DF)
22:49:25.186085 204.152.189.116.finger > 192.168.128.9.33060: . ack 3 win 5792
<nop,nop,timestamp 392369662 4505821> (DF)
22:49:25.214104 204.152.189.116.finger > 192.168.128.9.33060: P 1:709(708) ack 3
win 5792 <nop,nop,timestamp 392369662 4505821> (DF)
22:49:25.214110 204.152.189.116.finger > 192.168.128.9.33060: F 709:709(0) ack 3
win 5792 <nop,nop,timestamp 392369662 4505821> (DF)
22:49:25.275259 192.168.128.9.33060 > 204.152.189.116.finger: . ack 709 win 7080
<nop,nop,timestamp 4505832 392369662> (DF)
22:49:25.306309 192.168.128.9.33060 > 204.152.189.116.finger: . ack 710 win 7080
<nop,nop,timestamp 4505836 392369662> (DF)
22:49:25.451852 192.168.128.9.33060 > 204.152.189.116.finger: F 3:3(0) ack 710
win 7080 <nop,nop,timestamp 4505850 392369662> (DF)
22:49:25.686297 192.168.128.9.33060 > 204.152.189.116.finger: F 3:3(0) ack 710
win 7080 <nop,nop,timestamp 4505874 392369662> (DF)
22:49:25.710344 204.152.189.116.finger > 192.168.128.9.33060: . ack 4 win 5792
<nop,nop,timestamp 392369714 4505874> (DF)
 
16 packets received by filter
0 packets dropped by kernel
Comment 4 Pete Zaitcev 2003-06-01 22:34:39 EDT
Sorry for being stupid. The problem is traced down to the server.


Note You need to log in before you can comment on or make changes to this bug.