Bug 91386 - Corrupted display when using xinerama + Radeon 7500
Corrupted display when using xinerama + Radeon 7500
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-05-22 02:27 EDT by Youssef Makki
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-01 01:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
XFree86 configuration file (2.80 KB, text/plain)
2003-05-22 02:29 EDT, Youssef Makki
no flags Details
XFree86 Log file (49.56 KB, text/plain)
2003-05-22 02:30 EDT, Youssef Makki
no flags Details

  None (edit)
Description Youssef Makki 2003-05-22 02:27:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When using xinerama with my Radeon 7500 AGP, the display is corrupted, with each
window opened/moved/minimized leaving behind a permanent shadow of white boxes
on the screen. The mouse is also followed by a white box, though not always.
The primary display is somewhat usable if you move windows around to get rid of
the artifacts, but the secondary display shows only corrupted images.
I have tried the 4.3.0-10 rpms provided by mharris with no luck.
I should mention I tried this before upgrading XFree86 on what I believe was
4.3.0-5, the displays would not launch at all even with xinerama disabled.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. use attached XF86Config or similar for xinerama
2. startx
3. move mouse / launch windows

Actual Results:  Displays are both corrupted with artifacts on screen

Expected Results:  Usable displays

Additional info:
Comment 1 Youssef Makki 2003-05-22 02:29:45 EDT
Created attachment 91880 [details]
XFree86 configuration file
Comment 2 Youssef Makki 2003-05-22 02:30:48 EDT
Created attachment 91881 [details]
XFree86 Log file
Comment 3 Mike A. Harris 2004-10-01 01:14:31 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:


If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.