Bug 91389 - doesn't handle ext3,ext2 syntax in /etc/fstab
doesn't handle ext3,ext2 syntax in /etc/fstab
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-22 03:00 EDT by Seppo Pietikainen
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 14:32:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump from failed upgrade to 9.0 (45.10 KB, text/plain)
2003-05-22 03:02 EDT, Seppo Pietikainen
no flags Details
/etc/fstab from RH 7.3 (1.00 KB, text/plain)
2003-05-22 23:38 EDT, Seppo Pietikainen
no flags Details

  None (edit)
Description Seppo Pietikainen 2003-05-22 03:00:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208
Netscape/7.02

Description of problem:
Anaconda crashes whe upgrading from 7.3 to 9.0:
An unhandled exception has occurred.
...
Traceback (most recent call first):
File "/usr/lib/anaconda/gui.py"m line 761, in nextClicked
...
File "/usr/lib/anaconda/fsset.py", line 1260m in mountFileSystems
 if isinstance ( root.device , LogicalVolumeDevice );
 AttributeError:'NoneType' object has no attribute 'device'

And the update aborts.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install from RH CD
2.
3.
    

Actual Results:  RH9 update aborts

Expected Results:  RH7.3 should have been upgraded to 9.0

Additional info:
Comment 1 Seppo Pietikainen 2003-05-22 03:02:45 EDT
Created attachment 91883 [details]
Anaconda dump from failed upgrade to 9.0
Comment 2 Michael Fulbright 2003-05-22 11:30:42 EDT
Could you attach your /etc/fstab file please?
Comment 3 Seppo Pietikainen 2003-05-22 23:38:51 EDT
Created attachment 91908 [details]
/etc/fstab from RH 7.3 

I tried the upgrade with "LABEL=/ / ..." and with "/dev/hda3 / ..." without
change in behavior.

-- Seppo P.
Comment 4 Seppo Pietikainen 2003-05-22 23:55:26 EDT
I added /etc/fstab as an attachment. I'll try next with just 'ext2' for / and
/boot...

Some additional info:
Cpu:   AMD Athlon(tm) XP 1800+
Motherboard: Epox 8K5A (based on VIA KT333 AGPset (KT333 + VT8235)
Memory: 1GB

$ df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda3              54G  9.4G   42G  19% /
/dev/hda1              45M   13M   30M  29% /boot
none                  441M     0  441M   0% /dev/shm
/dev/hdb               37G  4.2G   30G  12% /free

/dev/hda identity (from /proc/ide/hda/identify): IC35L060AVER07-0

(I also tried to install with /dev/hdb commented out in 'fstab')

-- Seppo P (Fri May 23 06:56:50 EEST 2003)

Comment 5 Seppo Pietikainen 2003-05-23 08:40:51 EDT
I removed 'ext3' from the fstab entries and that did the trick!
So, now I have RH9.0 installed and running (with ext3)

I only wish that 'anaconda' would be more informative in its error messages ;(

I think this bug can be closed now...

-- Seppo P.
Comment 6 Jeremy Katz 2003-05-23 12:42:54 EDT
Updating subject to reflect root cause.
Comment 7 Jeremy Katz 2003-07-24 19:42:19 EDT
Fixed in CVS
Comment 8 Jeremy Katz 2006-04-24 14:32:37 EDT
Mass-closing lots of old bugs which are in MODIFIED (and thus presumed to be
fixed).  If any of these are still a problem, please reopen or file a new bug
against the release which they're occurring in so they can be properly tracked.

Note You need to log in before you can comment on or make changes to this bug.