Bug 91391 - gcj & ld linker error
Summary: gcj & ld linker error
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-22 09:01 UTC by Michael
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version: 3.3-7, 3.2.3-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-17 21:39:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael 2003-05-22 09:01:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I am getting a link error when trying to use gcj:

[mth@hucho bm]$ gcj Rbm.java
/usr/bin/ld: cannot find -lz
collect2: ld returned 1 exit status
[mth@hucho bm]$


Anthony Green <green@redhat.com> suggested that I do 'update zlib', but my zlib
is up to date. 

Red Hat 9 with all packages installed from the distribution.
System was upgraded from Red Hat 8 within a few days of the rh9 release. 
gcc works fine. 

I tried reinstalling packages ... no joy


Version-Release number of selected component (if applicable):
gcc-java-3.2.2-5, binutils-2.13.90.0.18-9, zlib-1.1.4-8

How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat 9.0
2. Install gcc-java
3. gcj MyTestProgram.java
    

Actual Results:  /usr/bin/ld: cannot find -lz
collect2: ld returned 1 exit status
:(

Expected Results:  :)

Additional info:

This is my first attempt to use gcj.
Don't think I've done anything wrong.

Comment 1 Michael 2003-05-22 09:17:03 UTC
Someone on <java@gcc.gnu.org> suggested that I install zlib-devel. 

I installed zlib-devel-1.1.4-8 from the rh9 distribution. 

Issue seems to be resolved. 

Shouldn't this be a dependency in the rpms? 



Note You need to log in before you can comment on or make changes to this bug.