Bug 91395 - Failed to make KDE shortcut keys with kmenuedit
Failed to make KDE shortcut keys with kmenuedit
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-22 06:35 EDT by Henrikki Almusa
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-13 06:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrikki Almusa 2003-05-22 06:35:48 EDT
Description of problem:
It seems that some of the kde shortcut keys do not work. The K menu editor
(kmenuedit) shows that the sckeys are there as well as checking the file
"~/.kde/share/config/khotkeys". Also the key combinations with multiple choices
do show the panel with names of the choices. 
 
Difference in files/directories i found were in "~/.kde/share" with directory
"applnk" holding the old changes in menu structure and directory "applnk-redhat"
holding the changes in new menu structure.


Version-Release number of selected component (if applicable):
kdebase-3.1-13

How reproducible:
Creating shortcut key with kmenuedit. Now it seems that if "applnk/" directory
has same structure as in "~/.kde/share/config/khotkeysrc" on same program, then
it works. But the "khotkeysrc" files structure is same as in "applnk-redhat" so
any new shortcut key that doesn't have file structure in "applnk" fails to work.

Steps to Reproduce:
1. Create shortcut key with kmenuedit.
2. Make sure that file for that menu entry is NOT in "~/.kde/share/applnk"
subdirs. But is in "applnk-redhat" so that menu editor shows it.
3. Try to use the shortcut key.
Comment 1 Ngo Than 2003-05-22 12:44:25 EDT
the ~/.kde/share/applnk directory is not used in RHL 8 and an newer anymore.
if you change your KDE menus with kmenuedit, the changes will be written in
~/.kde/share/applnk-redhat.

I have tried to reproduce this problem in KDE 3.1.2. But it's not reproduceable
in this Version.

Please update to KDE 3.1.2 from ftp.kde.org
Comment 2 Henrikki Almusa 2003-05-23 03:58:51 EDT
I've updated my kde to 3.1.2 from ftp.kde.org. However i still cannot make
shortcut keys. I have three shortcuts that work (win+t for terminal, win+a for
adobe acrobat and win+h for help). Others however wont work (eg win+m for menu
editor and kmail, win+w for konqueror and galeon, win+c for control center and
so on). 

Kdebase RPM: kdebase-3.1.2-0.9x.2
Comment 3 Henrikki Almusa 2003-05-26 02:16:57 EDT
After more testing at home over weekend, i've found out that if i assing more than one program 
on one key combo it fails. If there is only one program in given key combo then it works. Eg. 
win+c for calculator and control center fails, but after removing the caculator, it runs control 
center. This used to work in earlier kde 3.0.4 if i remember correctly (RH 7.3 updated version) 
with multiple programs. 
Comment 4 Henrikki Almusa 2003-06-03 04:55:29 EDT
Could this be tested: 
1) Make a shortcut key for a program with menu editor. Eg. crtl+alt+w for web browser. 
2) Test and see that shortcut key works. 
3) Add new program to that key combo. Eg. crtl+alt+w starts another web browser as well. 
4) Use key combo and get list with both programs. But neither works. 
 
Thanks. 
Comment 5 Ngo Than 2003-06-13 06:58:42 EDT
Hm, it's strange. I still cannot reproduce your bug here. it works fine for me

i have made short key Alt+Strg+C for kate and controll center. using this key
combo, i get a list box with both programs. clicking on one of this works for me.

I don't think it's a bug
Comment 6 Henrikki Almusa 2003-06-13 07:48:42 EDT
Sometimes i don't get everything right. I just proved that you're right. With mouse it works. 
However, using keyboard up and down arrow keys to select and enter/return (tested space and 
right/left arrow keys too) to choose fails. 
 
I hope it was meant to be able to use keyboards to select and choose as well. 

Note You need to log in before you can comment on or make changes to this bug.