Bug 914040 - gmp-ecm: FTBFS in rawhide
gmp-ecm: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gmp-ecm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19FTBFS
  Show dependency treegraph
 
Reported: 2013-02-22 04:28 EST by Dennis Gilmore
Modified: 2013-03-04 11:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 11:21:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-02-22 04:28:16 EST
Your package gmp-ecm failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4962680

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/2680/4962680/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/2680/4962680/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/2680/4962680/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Conrad Meyer 2013-02-22 13:33:38 EST
Bug or new behavior in GCC? This is now failing in %check (builds fine), wasn't before F-19 rebuild.
Comment 2 Jerry James 2013-02-23 18:40:53 EST
It turns out that ECM uses some knowledge of GMP internals, and that GMP 5.1 invalidated some of that knowledge.  I've plucked a couple of patches out of upstream's subversion repository to fix the problem.  I'll push a build shortly.
Comment 3 Conrad Meyer 2013-02-23 18:53:08 EST
Cool, thanks Jerry.

Note You need to log in before you can comment on or make changes to this bug.