Bug 914075 - hibernate-commons-annotations: FTBFS in rawhide
hibernate-commons-annotations: FTBFS in rawhide
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hibernate-commons-annotations (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
Depends On: 927887
Blocks: F19FTBFS
  Show dependency treegraph
 
Reported: 2013-02-22 04:32 EST by Dennis Gilmore
Modified: 2013-03-26 13:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: hibernate-commons-annotations-4.0.1-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-26 13:54:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-02-22 04:32:20 EST
Your package hibernate-commons-annotations failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4963646

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/3646/4963646/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/3646/4963646/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/3646/4963646/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Mat Booth 2013-03-26 08:14:11 EDT
Rebuild seems to fail:

[INFO] --- maven-processor-plugin:2.0.7:process-test (process-test) @ hibernate-commons-annotations ---
[INFO] Source directory: /builddir/build/BUILD/hibernate-commons-annotations-4.0.1.Final/target/generated-sources/apt-test added
[INFO] Adding compiler arg: -AloggingVersion=3.0
[INFO] Adding compiler arg: -AtranslationFilesPath=/builddir/build/BUILD/hibernate-commons-annotations-4.0.1.Final/src/main/resources/
[INFO] Adding compiler arg: -source
[INFO] Adding compiler arg: 1.6
[INFO] Adding compiler arg: -target
[INFO] Adding compiler arg: 1.6
[INFO] javac option: -proc:only
[INFO] javac option: -AloggingVersion=3.0
[INFO] javac option: -AtranslationFilesPath=/builddir/build/BUILD/hibernate-commons-annotations-4.0.1.Final/src/main/resources/
[INFO] javac option: -source
[INFO] javac option: 1.6
[INFO] javac option: -target
[INFO] javac option: 1.6
[INFO] javac option: -processor
[INFO] javac option: org.jboss.logging.processor.apt.LoggingToolsProcessor
[INFO] javac option: -d
[INFO] javac option: /builddir/build/BUILD/hibernate-commons-annotations-4.0.1.Final/target/test-classes
[INFO] javac option: -s
[INFO] javac option: /builddir/build/BUILD/hibernate-commons-annotations-4.0.1.Final/target/generated-sources/apt-test
[INFO] diagnostic warning: [options] bootstrap class path not set in conjunction with -source 1.6
[INFO] diagnostic /builddir/build/BUILD/hibernate-commons-annotations-4.0.1.Final/target/generated-sources/apt-test/org/hibernate/annotations/common/util/impl/Log_$logger.java:15: error: duplicate class: org.hibernate.annotations.common.util.impl.Log_$logger
public class Log_$logger
       ^
[INFO] diagnostic warning: The following options were not recognized by any processor: '[loggingVersion]'
[ERROR] error on execute: error during compilation
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Skipping Hibernate Commons Annotations
[INFO] This project has been banned from the build due to previous failures.
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 6.661s
[INFO] Finished at: Tue Mar 26 11:36:08 UTC 2013
[INFO] Final Memory: 27M/256M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.bsc.maven:maven-processor-plugin:2.0.7:process-test (process-test) on project hibernate-commons-annotations: Error executing: error during compilation -> [Help 1]
[ERROR] 


Likely caused by this upstream bug that was introduced in maven-processor-plugin 2.0.7:

http://code.google.com/p/maven-annotation-plugin/issues/detail?id=47

Reading that bug report, we probably need to upgrade maven-processor-plugin to 2.1.1
Comment 2 Mat Booth 2013-03-26 11:10:02 EDT
I build maven-processor-plugin 2.1.1 locally and can now build this package successfully. Just need to wait for bug 927887 to make its way into the buildroot before rebuilding :-)
Comment 3 Marek Goldmann 2013-03-26 11:13:15 EDT
Very good news! Thank you for this! After you submit the new mpp, I'll rebuild this package.
Comment 4 Mat Booth 2013-03-26 12:19:51 EDT
maven-processor-plugin-2.1.1 has now been built for F19+
Comment 5 Mat Booth 2013-03-26 13:39:05 EDT
I kicked off the re-builds.

Note You need to log in before you can comment on or make changes to this bug.