Bug 914113 - rhsmd Calling Deprecated hasNow Function
Summary: rhsmd Calling Deprecated hasNow Function
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.4
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: 960054
TreeView+ depends on / blocked
 
Reported: 2013-02-22 09:36 UTC by Enrique V. Bonet Esteban
Modified: 2018-12-04 15:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: rhsmd calling deprecated hasNow function Consequence: "DeprecationWarning: Call to deprecated function: hasNow" appears to the user. Fix: Remove a use of the deprecated hasNow() function. Result: No warning is displayed.
Clone Of:
Environment:
Last Closed: 2013-11-21 21:23:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1659 normal SHIPPED_LIVE subscription-manager and python-rhsm bug fix and enhancement update 2013-11-20 21:53:10 UTC

Description Enrique V. Bonet Esteban 2013-02-22 09:36:24 UTC
Description of problem:

The command:

/usr/libexec/rhsmd -s

Returns the message:

/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: hasNow
  category=DeprecationWarning)

This bug is similar to Red Hat Enterprise Linux 7.0 912707 bug.

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux 6.4

Comment 2 Bryan Kearney 2013-02-22 13:37:25 UTC
commit 5557f0bec9b582582a51d5207712c48c00d03d9d
Author: Bryan Kearney <bkearney@redhat.com>
Date:   Wed Feb 20 14:39:33 2013 -0500

    912707: Remove a use of the deprecated hasNow() function.

Comment 9 Tom Lane 2013-08-04 14:49:14 UTC
Would it be possible to get this shipped out sometime soon?  This bug results in nagmail to root every single day on my RHEL6 box, and I assume everybody else's too:

/etc/cron.daily/rhsmd:

/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: hasNow
  category=DeprecationWarning)

I realize it's purely cosmetic, but it's still pretty darn annoying for anyone who takes their sysadmin duties seriously and wants to keep an eye on root mail.

Comment 11 John Sefler 2013-09-20 18:10:05 UTC
Verifying Version....
[root@jsefler-6 ~]# rpm -q subscription-manager python-rhsm
subscription-manager-1.9.6-1.el6.x86_64
python-rhsm-1.9.6-1.el6.x86_64

[root@jsefler-6 ~]# /usr/libexec/rhsmd -s
[root@jsefler-6 ~]# 

VERIFIED: DeprecationWarning is no longer thrown.
This updated package will be included in the RHEL65 release.

Comment 12 errata-xmlrpc 2013-11-21 21:23:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html


Note You need to log in before you can comment on or make changes to this bug.