Bug 914131 - libgda: FTBFS in rawhide
libgda: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Haïkel Guémar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19FTBFS
  Show dependency treegraph
 
Reported: 2013-02-22 04:38 EST by Dennis Gilmore
Modified: 2013-03-19 11:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 11:08:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-02-22 04:38:34 EST
Your package libgda failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4966284

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/6284/4966284/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/6284/4966284/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/6284/4966284/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Dan Horák 2013-03-06 07:03:22 EST
the failure looks like this

...
Making all in canvas
make[3]: Entering directory `/builddir/build/BUILD/libgda-5.1.1/tools/browser/canvas'
  CC     browser-canvas.lo
  CC     browser-canvas-db-relations.lo
  CC     browser-canvas-fkey.lo
  CC     browser-canvas-column.lo
browser-canvas-db-relations.c: In function 'popup_add_table_cb':
browser-canvas-db-relations.c:827:36: warning: unused variable 'dcontents' [-Wunused-variable]
browser-canvas.c: In function 'browser_canvas_perform_auto_layout':
browser-canvas.c:854:2: error: incompatible type for argument 2 of 'agopen'
In file included from /usr/include/graphviz/types.h:49:0,
                 from /usr/include/graphviz/gvc.h:17,
                 from browser-canvas.c:33:
/usr/include/graphviz/cgraph.h:266:18: note: expected 'Agdesc_t' but argument is of type 'int'
browser-canvas.c:854:2: error: too few arguments to function 'agopen'
In file included from /usr/include/graphviz/types.h:49:0,
                 from /usr/include/graphviz/gvc.h:17,
                 from browser-canvas.c:33:
/usr/include/graphviz/cgraph.h:266:18: note: declared here
browser-canvas.c:855:9: warning: implicit declaration of function 'agnodeattr' [-Wimplicit-function-declaration]
browser-canvas.c:888:3: error: too few arguments to function 'agnode'
In file included from /usr/include/graphviz/types.h:49:0,
                 from /usr/include/graphviz/gvc.h:17,
                 from browser-canvas.c:33:
/usr/include/graphviz/cgraph.h:280:18: note: declared here
browser-canvas.c:932:5: error: too few arguments to function 'agedge'
In file included from /usr/include/graphviz/types.h:49:0,
                 from /usr/include/graphviz/gvc.h:17,
                 from browser-canvas.c:33:
/usr/include/graphviz/cgraph.h:291:18: note: declared here
make[3]: *** [browser-canvas.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/builddir/build/BUILD/libgda-5.1.1/tools/browser/canvas'
make[2]: Leaving directory `/builddir/build/BUILD/libgda-5.1.1/tools/browser'
make[1]: Leaving directory `/builddir/build/BUILD/libgda-5.1.1/tools'
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1
RPM build errors:
...


and probably it's caused by the use of cgraph by default in graphviz instead of graph
Comment 2 Haïkel Guémar 2013-03-19 11:08:14 EDT
Fixed in rawhide, the patch was submitted upstream and integrated in libgda 5.1.2
https://git.gnome.org/browse/libgda/commit/?id=cc5d429567e21ec62bf61b7e3b54348af11965b9
https://bugzilla.gnome.org/show_bug.cgi?id=695549

Note You need to log in before you can comment on or make changes to this bug.