Bug 914153 - libvirt-java: FTBFS in rawhide
libvirt-java: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt-java (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19FTBFS
  Show dependency treegraph
 
Reported: 2013-02-22 04:41 EST by Dennis Gilmore
Modified: 2013-03-18 17:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-18 17:23:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-02-22 04:41:46 EST
Your package libvirt-java failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4967139

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/7139/4967139/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/7139/4967139/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/7139/4967139/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Daniel Berrange 2013-02-22 10:54:39 EST
Upstream fix available

commit 307ba7a1974bf7fdd920b85c73015887873a4502
Author: Jiri Denemark <jdenemar@redhat.com>
Date:   Tue Nov 27 18:33:22 2012 +0100

    Fix build with jna >= 3.5.0
    
    Since jna-3.5.0, all subclasses of com.sun.jna.Structure are required to
    implement getFieldOrder method which is supposed to return a list of
    fields the wrapped structure contains.
Comment 2 Cole Robinson 2013-03-18 17:23:04 EDT
Fixed in libvirt-java-0.4.9-3.fc20

Note You need to log in before you can comment on or make changes to this bug.