Bug 914160 - lucene: FTBFS in rawhide
lucene: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lucene (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19FTBFS
  Show dependency treegraph
 
Reported: 2013-02-22 04:42 EST by Dennis Gilmore
Modified: 2013-02-26 10:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 10:00:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-02-22 04:42:32 EST
Your package lucene failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4967539

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/7539/4967539/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/7539/4967539/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/7539/4967539/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Krzysztof Daniel 2013-02-26 08:02:40 EST
Upstream is already on 4.1. This is the error while building 3:

compile-core:
    [javac] Compiling 15 source files to /builddir/build/BUILD/lucene-3.6.0/build/contrib/icu/classes/java
    [javac] /builddir/build/BUILD/lucene-3.6.0/contrib/icu/src/java/org/apache/lucene/analysis/icu/segmentation/BreakIteratorWrapper.java:24: error: cannot find symbol
    [javac] import com.ibm.icu.text.DictionaryBasedBreakIterator;
    [javac]                        ^
    [javac]   symbol:   class DictionaryBasedBreakIterator
    [javac]   location: package com.ibm.icu.text
    [javac] /builddir/build/BUILD/lucene-3.6.0/contrib/icu/src/java/org/apache/lucene/analysis/icu/segmentation/BreakIteratorWrapper.java:71: error: cannot find symbol
    [javac]         && !(breakIterator instanceof DictionaryBasedBreakIterator))
    [javac]                                       ^
    [javac]   symbol:   class DictionaryBasedBreakIterator
    [javac]   location: class BreakIteratorWrapper
    [javac] Note: /builddir/build/BUILD/lucene-3.6.0/contrib/icu/src/java/org/apache/lucene/analysis/icu/ICUTransformFilter.java uses or overrides a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] 2 errors
Comment 2 Severin Gehwolf 2013-02-26 08:21:53 EST
Yes. DictionaryBasedBreakIterator has been removed from icu4j v50:
See http://source.icu-project.org/repos/icu/icu4j/tags/release-50-1/readme.html#changes
Comment 3 Severin Gehwolf 2013-02-26 08:22:35 EST
I'm currently working on a patch.
Comment 4 Severin Gehwolf 2013-02-26 10:00:57 EST
Fixed in rawhide: http://koji.fedoraproject.org/koji/buildinfo?buildID=398552

Note You need to log in before you can comment on or make changes to this bug.