Bug 914202 - mysql-connector-odbc: FTBFS in rawhide
mysql-connector-odbc: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mysql-connector-odbc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19FTBFS
  Show dependency treegraph
 
Reported: 2013-02-22 04:48 EST by Dennis Gilmore
Modified: 2013-03-04 06:23 EST (History)
2 users (show)

See Also:
Fixed In Version: mysql-connector-odbc-5.1.11-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 06:23:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch illustrates what types has been changed (1.12 KB, patch)
2013-02-22 08:14 EST, Honza Horak
no flags Details | Diff

  None (edit)
Description Dennis Gilmore 2013-02-22 04:48:12 EST
Your package mysql-connector-odbc failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4969014

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/9014/4969014/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/9014/4969014/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/9014/4969014/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Honza Horak 2013-02-22 08:14:11 EST
Created attachment 701189 [details]
This patch illustrates what types has been changed

The problem is that "const" has been added to some char variables/function types in MariaDB header files. The patch attached illustrates the particular cases.

However, I don't think we should fix that in mysql-connector-odbc, but we should rather push mariadb to stay compatible with mysql in case of header files (reported as MariaDB upstream bug: https://mariadb.atlassian.net/browse/MDEV-4195).

Another thing is that there is already a new version of mysql-connector-odbc-5.2.4, so it would make sense to take a look at it if it suffers from this issue as well (but I haven't managed to build it check it yet).
Comment 2 Honza Horak 2013-03-04 06:23:51 EST
(In reply to comment #1)
> However, I don't think we should fix that in mysql-connector-odbc, but we
> should rather push mariadb to stay compatible with mysql in case of header
> files (reported as MariaDB upstream bug:
> https://mariadb.atlassian.net/browse/MDEV-4195).

Well, the situation is a bit different -- the symbols where "const" has been added are not a part of the exported API in Fedora. Instead, they're manually extracted from mysql/mariadb source and added to mysql-connector-odbc source in order to build it successfully. So I've only added the "const" for now, which should be enough for now:

https://koji.fedoraproject.org/koji/buildinfo?buildID=399723

Note You need to log in before you can comment on or make changes to this bug.