Bug 914215 - newsx: FTBFS in rawhide
newsx: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: newsx (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
:
Depends On: 924938
Blocks: F19FTBFS
  Show dependency treegraph
 
Reported: 2013-02-22 04:49 EST by Dennis Gilmore
Modified: 2013-03-25 05:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-25 05:52:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-02-22 04:49:30 EST
Your package newsx failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4969363

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/9363/4969363/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/9363/4969363/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/9363/4969363/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Dominik 'Rathann' Mierzejewski 2013-03-25 05:46:59 EDT
Log excerpt:

Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.UedW4H
+ umask 022
+ cd /builddir/build/BUILD
+ cd newsx-1.6
+ autoreconf -f -i
Can't locate Carp.pm in @INC (@INC contains: /usr/share/autoconf /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/share/autoconf/Autom4te/Channels.pm line 72.
BEGIN failed--compilation aborted at /usr/share/autoconf/Autom4te/Channels.pm line 72.
Compilation failed in require at /usr/share/autoconf/Autom4te/ChannelDefs.pm line 19.
BEGIN failed--compilation aborted at /usr/share/autoconf/Autom4te/ChannelDefs.pm line 19.
Compilation failed in require at /usr/bin/autoreconf line 39.
BEGIN failed--compilation aborted at /usr/bin/autoreconf line 39.

This is partly due to main perl package providing perl(Carp), but not including the actual module (which is in perl-Carp package). See bug 927170.

Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.