Bug 91422 - Conflicts: thttpd should probably be removed
Summary: Conflicts: thttpd should probably be removed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-22 14:12 UTC by Matthias Saou
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version: 2.0.45-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-28 19:35:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Saou 2003-05-22 14:12:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509

Description of problem:
I've built a thttpd rpm package, being very careful in not overlapping at all
with apache/httpd. For this, I've renamed the htpasswd binary and man page to
htpasswd.thttpd, and used /var/www/thttpd instead of directly /var/www as the
web root.
I intend to use both on the same server, thttpd on one IP address and httpd on
another... but I can't right now, just because of the "Conflicts: thttpd" that
seems to have been present in httpd and apache for a while now.

Would it be possible to remove it from future versions? I really think it's
irrelevant, and it's the only one listed (no caudium, boa or zeus). Right now it
won't solve my problem for existing Red Hat Linux releases, but in the long term
it would allow easy parallel installation to have thttpd serving static content
on a different port or IP address of the same server httpd/apache is running on.

Matthias

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -q --conflicts httpd

Actual Results:  thttpd

Expected Results:  (nothing...)

Additional info:

Comment 1 Joe Orton 2003-05-22 15:39:20 UTC
Sounds reasonable, I'll do it for the next build.

Comment 2 Joe Orton 2003-05-28 19:35:15 UTC
Fixed in httpd-2.0.45-6, thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.