Bug 914279 - regression in 1.6.0-10.el6: Mousepointer and selections not drawn properly
Summary: regression in 1.6.0-10.el6: Mousepointer and selections not drawn properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rdesktop
Version: 6.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 835616 960054
TreeView+ depends on / blocked
 
Reported: 2013-02-22 09:56 UTC by Dirk Gfroerer
Modified: 2018-12-04 15:03 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 06:08:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1556 normal SHIPPED_LIVE rdesktop bug fix and enhancement update 2013-11-20 21:40:24 UTC

Description Dirk Gfroerer 2013-02-22 09:56:31 UTC
Description of problem:
After upgrading to RHEL 6.4 I do observe a regression within rdesktop. When connecting to my Windows XP and Windows 7 machines, e.g. mouse cursor does not change to the "resize mouse cursor" when resizing a window.
If I do select cells within Excel the selected cell is not properly highlighted.

Downgrading to rdesktop-1.6.0-8.el6_0.1.x86_64.rpm resolves these issues

Version-Release number of selected component (if applicable):
rdesktop.x86_64 0:1.6.0-10.el6

How reproducible:
everytime

Steps to Reproduce:
1. Upgrade system to RHEL 6.4
2. Connect using rdesktop
   Problem is observed when using no command line parameters but the host or in combination with '-a32 -5 -xl -k de -r clipboard:CLIPBOARD'
3. Try to resize a window. It works, but the mouse pointer icon does not change. Select a cell within MS Excel. Selection is not being drawn properly.
  
Actual results:
Mousepointer not shown properly, redraw errors and selection not being displayed properly.

Expected results:
Same behaviour as before the upgrade.

Additional info:
Console shows:
Autoselected keyboard map en-us
WARNING: Remote desktop does not support colour depth 24; falling back to 16
NOT IMPLEMENTED: RDP5 opcode 11
NOT IMPLEMENTED: RDP5 opcode 11
NOT IMPLEMENTED: RDP5 opcode 11
ERROR: get cursor 0
NOT IMPLEMENTED: RDP5 opcode 11
ERROR: get cursor 2
ERROR: get cursor 2
NOT IMPLEMENTED: RDP5 opcode 11
ERROR: get cursor 2
NOT IMPLEMENTED: RDP5 opcode 11
ERROR: get cursor 2
ERROR: get cursor 4
ERROR: get cursor 2
ERROR: get cursor 2
ERROR: get cursor 1
NOT IMPLEMENTED: RDP5 opcode 11
NOT IMPLEMENTED: RDP5 opcode 11
NOT IMPLEMENTED: RDP5 opcode 11
NOT IMPLEMENTED: RDP5 opcode 11
ERROR: get cursor 0
NOT IMPLEMENTED: RDP5 opcode 11
NOT IMPLEMENTED: RDP5 opcode 11
NOT IMPLEMENTED: RDP5 opcode 11
NOT IMPLEMENTED: RDP5 opcode 11
ERROR: get cursor 0
ERROR: get cursor 0
NOT IMPLEMENTED: RDP5 opcode 11
NOT IMPLEMENTED: secondary order 7
NOT IMPLEMENTED: brush 129
NOT IMPLEMENTED: brush 129
NOT IMPLEMENTED: brush 129
NOT IMPLEMENTED: brush 129
NOT IMPLEMENTED: brush 129
NOT IMPLEMENTED: brush 129
NOT IMPLEMENTED: brush 129
NOT IMPLEMENTED: brush 129
NOT IMPLEMENTED: RDP5 opcode 11
ERROR: get cursor 0
ERROR: get cursor 2
ERROR: get cursor 0
ERROR: get cursor 1

and so on

Comment 2 bapruski 2013-03-26 17:41:37 UTC
I can add another problem to the list. The scroll bar is not painted properly (all the previously painted images are still visible therefore it is almost impossible to know what it the current position of the slider button)

Comment 5 G. Bersano 2013-04-18 08:32:40 UTC
I confirm all the mentioned problems and the workaround too, same version.
Despite my reluctance to work in windows sometimes I have to do it but this bug makes rdesktop almost unusable.

TIA for taking care of this,
Giorgio.

Comment 6 Richard Arends 2013-05-03 09:08:43 UTC
A 'me too'. Many of the users in the company I work for, are complaining about this issue. 

I downloaded the rdesktop SRPM and rebuilded it using rdesktop 1.7.1 (the latest) instead of 1.6.0 and that fixed the problem for us. I also removed all references to the patches in the spec file.

Hopefully someone at Red Hat can fix, so we can roll out a RH maintained RPM instead of our custom one.

Regards,

Richard.

Comment 8 David Halliwell 2013-05-17 11:01:05 UTC
We have the same symptoms since upgrading to 1.6.0-10.  We have also see occasional problems (which we believe are related) where mouse and keyboard focus are lost from both the rdesktop session and the X session.

In this case, shelling in from a different machine and killing the rdesktop process releases the mouse and keyboard focus back to X.

I've opened a support case #00843951.

Thanks,

David

Comment 11 Tomas Pelka 2013-09-20 08:38:33 UTC
With the new rdesktop-1.7.1-1.el6
* error messages and all the shell messages are gone
* cursor changing in the remote desktop window
* can see any scrolbar miss renderings

Unfortunately I cant check the Excel issue, but assume it is connected to alredy mentioned ones.

Moving to verified.

Comment 12 errata-xmlrpc 2013-11-21 06:08:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1556.html


Note You need to log in before you can comment on or make changes to this bug.